summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntti Jarvinen <antti.jarvinen@katiska.org>2015-12-20 22:22:14 +0200
committerAntti Jarvinen <antti.jarvinen@katiska.org>2015-12-20 22:22:14 +0200
commit1ffd858364a77cf5a1e37d1bbe5e10a055eaa5b1 (patch)
tree57643f9cbe92f624ef8aee04422c189847113052 /net-p2p/classified-ads/classified-ads-0.09_p20151220.ebuild
parentprofiles: unmask removed packages (diff)
downloadgentoo-1ffd858364a77cf5a1e37d1bbe5e10a055eaa5b1.tar.gz
gentoo-1ffd858364a77cf5a1e37d1bbe5e10a055eaa5b1.tar.bz2
gentoo-1ffd858364a77cf5a1e37d1bbe5e10a055eaa5b1.zip
net-p2p/classified-ads: Fix bug 568874 - use correct qmake version
Modifies so ebuild so that it uses same version of qmake with test suite as it used with rest of the software. This includes also fix for bug 563606 where miniupnpc version bumb changed the API making classified-ads to not compile any more. Reported-By: Michael Palimaka <kensington@gentoo.org> Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-p2p/classified-ads/classified-ads-0.09_p20151220.ebuild')
-rw-r--r--net-p2p/classified-ads/classified-ads-0.09_p20151220.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/net-p2p/classified-ads/classified-ads-0.09_p20151220.ebuild b/net-p2p/classified-ads/classified-ads-0.09_p20151220.ebuild
new file mode 100644
index 000000000000..876103093017
--- /dev/null
+++ b/net-p2p/classified-ads/classified-ads-0.09_p20151220.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PLOCALES="en fi sv da"
+PLOCALE_BACKUP="en"
+inherit qt4-r2 vcs-snapshot qmake-utils
+
+COMMIT_ID="c761d4e7124ebe9c76bc1529b27fe9c0aa1c2078"
+DESCRIPTION="Program for displaying classified advertisement items"
+HOMEPAGE="http://katiska.org/classified-ads/"
+SRC_URI="https://github.com/operatornormal/classified-ads/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz \
+ https://github.com/operatornormal/classified-ads/blob/graphics/preprocessed.tar.gz?raw=true \
+ -> classified-ads-graphics-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug doc test"
+
+RDEPEND="dev-libs/openssl:0
+ dev-libs/qjson
+ >=net-libs/libnatpmp-20130911
+ <=net-libs/libnatpmp-20140401-r1
+ >=net-libs/miniupnpc-1.8
+ sys-apps/file
+ sys-devel/gettext
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtsql:4[sqlite]
+ dev-qt/qtgui:4[debug?]"
+
+DEPEND="${RDEPEND}
+ dev-qt/qttest:4
+ sys-devel/gdb:0
+ doc? ( app-doc/doxygen[dot] )
+ test? ( dev-libs/libgcrypt:0 )
+ "
+
+src_prepare() {
+ # preprocessed graphics are unpacked into wrong directory
+ # so lets move them into correct location:
+ mv ../classified-ads-graphics-${PV}/* ui/ || die
+ # then just run qmake
+ qt4-r2_src_prepare
+}
+
+src_compile() {
+ qt4-r2_src_compile
+ if use doc; then
+ cd doc || die
+ doxygen || die
+ fi
+}
+
+src_test() {
+ cd test || die "test suite missing"
+ $(qt4_get_bindir)/qmake || die "test suite configure failed"
+ emake
+
+ if [ -e $HOME/.classified_ads/sqlite_db ]; then
+ mv $HOME/.classified_ads/sqlite_db $HOME/.classified_ads/sqlite_db.backup \
+ || die "datafile backup failed"
+ fi
+ ./testca
+ result=$?
+ rm $HOME/.classified_ads/sqlite_db || true
+
+ if [ -e $HOME/.classified_ads/sqlite_db.backup ]; then
+ mv $HOME/.classified_ads/sqlite_db.backup $HOME/.classified_ads/sqlite_db \
+ || die "datafile restore failed"
+ fi
+
+ if [ $result != "0" ]; then
+ die "test failed with code $result"
+ fi
+
+ return $result
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}" DESTDIR="${D}"
+ use doc && dodoc -r doc/doxygen.generated/html/
+}