summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntti Jarvinen <antti.jarvinen@katiska.org>2016-04-28 19:19:32 +0300
committerIan Delaney <idella4@gentoo.org>2016-05-03 11:41:44 +0800
commit37e876bc29f2c811383c3d0fdc8d7478ecab9578 (patch)
tree197918ce4358940034ec46812d9b44aea83eb11c /net-p2p/classified-ads
parentnet-p2p/classified-ads: Classified ads v0.10 version bump. - changed way how ... (diff)
downloadgentoo-37e876bc29f2c811383c3d0fdc8d7478ecab9578.tar.gz
gentoo-37e876bc29f2c811383c3d0fdc8d7478ecab9578.tar.bz2
gentoo-37e876bc29f2c811383c3d0fdc8d7478ecab9578.zip
net-p2p/classified-ads: v0.10 version bump. Changes dependency qt4->qt5, has EAPI=6.
Package-Manager: portage-2.2.26 Closes: https://github.com/gentoo/gentoo/pull/1327 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'net-p2p/classified-ads')
-rw-r--r--net-p2p/classified-ads/classified-ads-0.10.ebuild30
1 files changed, 16 insertions, 14 deletions
diff --git a/net-p2p/classified-ads/classified-ads-0.10.ebuild b/net-p2p/classified-ads/classified-ads-0.10.ebuild
index a792705205c9..d7f75da81b02 100644
--- a/net-p2p/classified-ads/classified-ads-0.10.ebuild
+++ b/net-p2p/classified-ads/classified-ads-0.10.ebuild
@@ -2,10 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PLOCALES="en fi sv da uk"
PLOCALE_BACKUP="en"
-inherit qt4-r2 qmake-utils virtualx vcs-snapshot
+inherit qmake-utils virtualx vcs-snapshot
COMMIT_ID="cd0652c52f86f6284b793f26e5362bc8fb8a7118"
DESCRIPTION="Program for displaying classified advertisement items"
@@ -21,37 +21,40 @@ KEYWORDS="~amd64 ~x86"
IUSE="debug doc test"
RDEPEND="dev-libs/openssl:0
- dev-libs/qjson
>=net-libs/libnatpmp-20130911
<=net-libs/libnatpmp-20140401-r1
>=net-libs/miniupnpc-1.8
sys-apps/file
sys-devel/gettext
- dev-qt/qtcore:4[ssl]
- dev-qt/qtsql:4[sqlite]
- dev-qt/qtgui:4[debug?]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtwidgets:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtmultimedia:5[widgets]
dev-qt/qt-mobility[multimedia]
- dev-qt/qtmultimedia:4
+ dev-qt/qtprintsupport:5
media-libs/opus"
DEPEND="${RDEPEND}
- dev-qt/qttest:4
+ dev-qt/qttest:5
sys-devel/gdb:0
doc? ( app-doc/doxygen[dot] )
test? ( dev-libs/libgcrypt:0
- ${VIRTUALX_DEPEND} )
- "
+ ${VIRTUALX_DEPEND} )"
src_prepare() {
# preprocessed graphics are unpacked into wrong directory
# so lets move them into correct location:
mv ../classified-ads-graphics-${PV}/* ui/ || die
+ # possible patches
+ eapply_user
# then just run qmake
- qt4-r2_src_prepare
+ eqmake5
}
src_compile() {
- qt4-r2_src_compile
+ emake
if use doc; then
cd doc || die
doxygen || die
@@ -70,8 +73,7 @@ src_install() {
# virtualx requires a command that returns number, and does not just die:
test_suite() {
cd test || return -1
- echo qmake
- "$(qt4_get_bindir)"/qmake || return -2
+ eqmake5 || return -2
emake
# test suite will create files under $HOME, set $HOME to point to
# safe location, ideas stolen from