summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-01-04 20:17:19 -0500
committerCraig Andrews <candrews@gentoo.org>2020-01-04 20:18:10 -0500
commit0297330ba7a6281e35ff5e7e8062284c00d709e5 (patch)
treee5495f190441a3b56a6b80b8dc5d4c0dcbd531ce /net-p2p/cpuminer-opt
parentdev-libs/libinput: Bump to version 1.15.0. Removed old (diff)
downloadgentoo-0297330ba7a6281e35ff5e7e8062284c00d709e5.tar.gz
gentoo-0297330ba7a6281e35ff5e7e8062284c00d709e5.tar.bz2
gentoo-0297330ba7a6281e35ff5e7e8062284c00d709e5.zip
net-p2p/cpuminer-opt: 3.11.0 version bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p/cpuminer-opt')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.11.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 857306067b49..2c92bf787db4 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -3,3 +3,4 @@ DIST cpuminer-opt-3.10.4.tar.gz 1958764 BLAKE2B 2d7aaffe51625d958c856612680de1d7
DIST cpuminer-opt-3.10.5.tar.gz 1963667 BLAKE2B 6906aef3b8e74ab917a1c9dcbf48eb5442076c5fc0c88c2491d567f673431350828a55932e9c31677d5cd67893f4939bd8eb85728145bcc633ef108037aab268 SHA512 cf7dadd2ac3d7d55a7648540d044b110be3f78a4babe35b1cdaf9dcd2a259c4b7b8f61a4524dd4d8c932aeeff902c36b6f24f59311bc6d29cdccc7ef45f0876f
DIST cpuminer-opt-3.10.6.tar.gz 1973545 BLAKE2B 9dda961f1dbaa24517389559fac599270ba7791510e09b287cc03bcc81b62ee13e81c852abf77de381249873c78595ac922acc95ad2a470f6d3e322cc1a7cd12 SHA512 a991d63be0f27a3a2e17ada84f0c149c284441b934684173f502666b84f8e46c97af91113e0aac5c69630ee4e3dd37ce135131a72956eadc27de542f4a34c380
DIST cpuminer-opt-3.10.7.tar.gz 1978510 BLAKE2B a770d663f5e01386656f80d64dbeee806aa82e8eafee9630fe1edbb0941a8d580c7d9f4c02d0a94045a3874d688ddf55b731e0c4e715dce57f174a237e078ee5 SHA512 c5b4dc6d600867391db3828a8f4ab962bbe3b73dd5ccd90610f552456015f12cad8dcff2ecec20a4f0ddecb96b9cba55dbd762ae5bbb7000292632c334f721eb
+DIST cpuminer-opt-3.11.0.tar.gz 1999976 BLAKE2B c411265ba9d9d380601cbf2e2ca314c95d299d91e900140c4f2a6f7452325c5e6315feadb2b9096df119483d08fe51262a09d535a28ac6b50bf7793ee1e357f6 SHA512 28868d525201d7f9e71601d048b64c82d68329c571d12ada0f681711d2d8b4a4644a6ccc12f2cbb4d0f67c38f991db3cdd39e5dd7e9ad9932cbc5ad9acdaf50b
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.11.0.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.11.0.ebuild
new file mode 100644
index 000000000000..a5d436b3b8b8
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.11.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}