summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-01-06 17:19:02 -0500
committerCraig Andrews <candrews@gentoo.org>2020-01-06 17:19:02 -0500
commit473c4cee940561ce97fc9a7226aed3f42cbf6123 (patch)
tree0f1f8bb493bfe89db31f4f44e568362663dfc843 /net-p2p/cpuminer-opt
parentdev-libs/rocm-opencl-driver: remove unused patch(es) (diff)
downloadgentoo-473c4cee940561ce97fc9a7226aed3f42cbf6123.tar.gz
gentoo-473c4cee940561ce97fc9a7226aed3f42cbf6123.tar.bz2
gentoo-473c4cee940561ce97fc9a7226aed3f42cbf6123.zip
net-p2p/cpuminer-opt: 3.11.1 version bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p/cpuminer-opt')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.11.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 4de38c1da546..a9f2fc785c99 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
DIST cpuminer-opt-3.11.0.tar.gz 1999976 BLAKE2B c411265ba9d9d380601cbf2e2ca314c95d299d91e900140c4f2a6f7452325c5e6315feadb2b9096df119483d08fe51262a09d535a28ac6b50bf7793ee1e357f6 SHA512 28868d525201d7f9e71601d048b64c82d68329c571d12ada0f681711d2d8b4a4644a6ccc12f2cbb4d0f67c38f991db3cdd39e5dd7e9ad9932cbc5ad9acdaf50b
+DIST cpuminer-opt-3.11.1.tar.gz 1924178 BLAKE2B 1ed7f07f89c94e7e15ac370e7873e5b37ec45c5b0132c3a8f2772558eb37666f1db41fbf78311f539d69f2b0858ef91478a9b1b469220e09fe07e20bd0147db3 SHA512 af6a70e0e60d7c6ab904fe29f37ba3f18327d9eb7b9700b53c28ca5d4f6693d124b01a9f382f608f4449f5a412ca57216bac354bc40d1793a1f1d40f7191dd7b
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.11.1.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.11.1.ebuild
new file mode 100644
index 000000000000..a5d436b3b8b8
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.11.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}