summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-07-02 16:33:10 -0400
committerCraig Andrews <candrews@gentoo.org>2019-07-02 16:38:35 -0400
commit92986880f5714bbe783c995af1f3c12ce698acc9 (patch)
tree97c546b0b08bd4696883a5fc2a92f407ee450f53 /net-p2p/cpuminer-opt
parentmedia-plugins/kodi-pvr-vuplus: 3.26.0 version bump (diff)
downloadgentoo-92986880f5714bbe783c995af1f3c12ce698acc9.tar.gz
gentoo-92986880f5714bbe783c995af1f3c12ce698acc9.tar.bz2
gentoo-92986880f5714bbe783c995af1f3c12ce698acc9.zip
net-p2p/cpuminer-opt: 3.9.5.1 version bump
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p/cpuminer-opt')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.9.5.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 0fca58ec98d4..c79f0b74a349 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -10,4 +10,5 @@ DIST cpuminer-opt-3.9.2.5.tar.gz 1781488 BLAKE2B cd79f8cc363918d6db62b1970086a57
DIST cpuminer-opt-3.9.2.tar.gz 1770769 BLAKE2B 75413f98b522e30647c9e312e1a23ee5dd3d761780dad7617b68b20d08e123ddd256f70f1494f565abe67997bb1c5fd1401ccd21e7f5492182c7ec2619bc8e00 SHA512 ce12c867706a3caed0104859a8f2366af85497b493f8c2a8c87a45f430abb45a29c415889c8f219450ac2f4e10bd4482f6dbe9dd125e1dde98c8a25e3fdad8c8
DIST cpuminer-opt-3.9.3.1.tar.gz 1781503 BLAKE2B 3f5df07d6d68343bb074367e3296e08c7e958edfcd3c2d63da83b98e8ce635a8b27d0c871061087908840b665a27556833de8d8106557f6794e9ad35d5a9d53e SHA512 d8f0c298c03e4f309f28a2b555f039212d66e6a9804fa2a1f7d0a8bd3d69969c48f1ac51570b10d5bf9bc695f7a9f91e884298d85d1b6a876d5d3a8974d3b890
DIST cpuminer-opt-3.9.4.tar.gz 1787750 BLAKE2B 74c3304f743c7650968f90606f7f12fa26b316634f29c5157cbe774ecbe155cc950d9ab44c227909aacbabba4af98379e22a971956a1b8560ce4c096822d6a88 SHA512 f2dc2dbdafb7c7028521aeec5212df87274b6a5f130c116e58fc575d4cd30dcaf10b4ff59f79e782bc6466db65758770c2f4717e446641e29a3eb9ccf4770011
+DIST cpuminer-opt-3.9.5.1.tar.gz 1789716 BLAKE2B 8c2eb876837f86d39c9c665392172654fee8a969c0463e76adf47c1ae631f268ebfacfdddd662c5edb79db3469af2299916a54c3b3ec88a8d3bce62878a0ecb0 SHA512 1da67a4a063781502bc7a2062331388205c6bedec1bbbfd447727b4d3aa23591d794ba8c4b59a9671f232d102298b448b539e54f723d86525ee19ae1e4d7fe52
DIST cpuminer-opt-3.9.5.tar.gz 1787557 BLAKE2B e6d5623c2752a4dc6eae669e6daba2f3a0a8542863a3268e632b6d0e4ee2cf203614cebd8e41e33d71c58262bfc90d1df0c7eab0d72db28d8df6f40795bfd887 SHA512 7fc2d7afa9a85a6ec9a9a87eee18f68e61f4875b579bcca3e8d4fc4541a3085ae59b566d2851b978abdf27efeeaa310db430c3efce07bb422548d0bddfda1fa4
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.9.5.1.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.9.5.1.ebuild
new file mode 100644
index 000000000000..666d27ee1c02
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.9.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}