summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-11 19:59:40 +0100
committerBen Kohler <bkohler@gentoo.org>2021-02-12 07:44:39 -0600
commite13a6c866c1751ba8886bd0089a6646d58fc9e63 (patch)
treea5d2d36d4dfa99fbe8d011be772b75867f9c85f5 /net-p2p/dbhub
parentnet-misc/liveice: Apply gcc-10 workaround (diff)
downloadgentoo-e13a6c866c1751ba8886bd0089a6646d58fc9e63.tar.gz
gentoo-e13a6c866c1751ba8886bd0089a6646d58fc9e63.tar.bz2
gentoo-e13a6c866c1751ba8886bd0089a6646d58fc9e63.zip
net-p2p/dbhub: Port to EAPI 7
* Apply gcc-10 workaround (dead upstream since 2008) Closes: https://bugs.gentoo.org/707458 Closes: https://bugs.gentoo.org/680728 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-p2p/dbhub')
-rw-r--r--net-p2p/dbhub/dbhub-0.451-r1.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/net-p2p/dbhub/dbhub-0.451-r1.ebuild b/net-p2p/dbhub/dbhub-0.451-r1.ebuild
index 829b4d89b17b..b1fef15f647a 100644
--- a/net-p2p/dbhub/dbhub-0.451-r1.ebuild
+++ b/net-p2p/dbhub/dbhub-0.451-r1.ebuild
@@ -1,27 +1,28 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools
+EAPI=7
+
+inherit autotools flag-o-matic
DESCRIPTION="Hub software for Direct Connect, fork of opendchub"
-HOMEPAGE="http://www.dbhub.org"
+HOMEPAGE="https://sourceforge.net/projects/dbhub/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tbz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="debug perl nls switch-user"
+IUSE="debug nls perl switch-user"
-DEPEND="perl? ( dev-lang/perl )
+DEPEND="
+ perl? ( dev-lang/perl )
switch-user? ( sys-libs/libcap )"
-
RDEPEND="${DEPEND}"
PATCHES=(
- "${FILESDIR}/${PN}-gentoo.patch"
- "${FILESDIR}/${PN}-no-dynaloader.patch"
- "${FILESDIR}/${PN}-fix-buffer-overflows.patch"
+ "${FILESDIR}"/${PN}-gentoo.patch
+ "${FILESDIR}"/${PN}-no-dynaloader.patch
+ "${FILESDIR}"/${PN}-fix-buffer-overflows.patch
)
src_prepare() {
@@ -30,9 +31,10 @@ src_prepare() {
}
src_configure() {
+ append-flags -fcommon
econf \
+ $(use_enable debug) \
$(use_enable nls) \
$(use_enable perl) \
- $(use_enable switch-user switch_user) \
- $(use_enable debug)
+ $(use_enable switch-user switch_user)
}