summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-10-09 16:52:51 -0400
committerCraig Andrews <candrews@gentoo.org>2019-10-11 11:07:09 -0400
commit0636a6c1baa2467b6642ea60227ba5af62388bb0 (patch)
tree483f6dd4711100850c9af7d57f153cc6e7a62e59 /net-p2p/deluge/deluge-9999.ebuild
parentdev-libs/gecode: Remove last-rited pkg (diff)
downloadgentoo-0636a6c1baa2467b6642ea60227ba5af62388bb0.tar.gz
gentoo-0636a6c1baa2467b6642ea60227ba5af62388bb0.tar.bz2
gentoo-0636a6c1baa2467b6642ea60227ba5af62388bb0.zip
net-p2p/deluge: 2.0.3 version bump
Closes: https://bugs.gentoo.org/688024 Closes: https://github.com/gentoo/gentoo/pull/12548 Closes: https://github.com/gentoo/gentoo/pull/9327 Closes: https://github.com/gentoo/gentoo/pull/13243 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p/deluge/deluge-9999.ebuild')
-rw-r--r--net-p2p/deluge/deluge-9999.ebuild56
1 files changed, 25 insertions, 31 deletions
diff --git a/net-p2p/deluge/deluge-9999.ebuild b/net-p2p/deluge/deluge-9999.ebuild
index 9989834d9973..f347e4c3ee39 100644
--- a/net-p2p/deluge/deluge-9999.ebuild
+++ b/net-p2p/deluge/deluge-9999.ebuild
@@ -1,24 +1,21 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
DISTUTILS_SINGLE_IMPL=1
-PLOCALES="af ar ast be bg bn bs ca cs cy da de el en_AU en_CA en_GB eo es et eu fa fi fo fr fy ga gl he hi hr hu id is it iu ja ka kk km kn ko ku ky la lb lt lv mk ml ms nap nb nds nl nn oc pl pms pt pt_BR ro ru si sk sl sr sv ta te th tl tlh tr uk ur vi zh_CN zh_HK zh_TW"
-inherit distutils-r1 eutils systemd l10n
+inherit distutils-r1 systemd
DESCRIPTION="BitTorrent client with a client/server model"
HOMEPAGE="https://deluge-torrent.org/"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="git://deluge-torrent.org/${PN}.git
- http://git.deluge-torrent.org/${PN}"
- SRC_URI=""
+ EGIT_REPO_URI="https://git.deluge-torrent.org/${PN}"
else
- SRC_URI="http://download.deluge-torrent.org/source/${P}.tar.bz2"
- KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+ SRC_URI="http://download.deluge-torrent.org/source/2.0/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-2"
@@ -26,37 +23,41 @@ SLOT="0"
IUSE="console geoip gtk libnotify sound webinterface"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
- sound? ( gtk )
libnotify? ( gtk )
+ sound? ( gtk )
"
-PATCHES=(
- "${FILESDIR}/${PN}-1.3.12-fix_scheduler_plugin.patch"
-)
-CDEPEND=">=net-libs/libtorrent-rasterbar-0.14.9[python,${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
+DEPEND="net-libs/libtorrent-rasterbar[python,${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-util/intltool
+ dev-python/wheel[${PYTHON_USEDEP}]
acct-group/deluge
acct-user/deluge"
-RDEPEND="${CDEPEND}
- dev-python/chardet[${PYTHON_USEDEP}]
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/rencode[${PYTHON_USEDEP}]
dev-python/setproctitle[${PYTHON_USEDEP}]
- || ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-web-13.0[${PYTHON_USEDEP}]
- )
- geoip? ( dev-libs/geoip )
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/twisted-17.1.0[crypt,${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-4.4.2[${PYTHON_USEDEP}]
+ geoip? ( dev-python/geoip-python[${PYTHON_USEDEP}] )
gtk? (
sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.12[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
gnome-base/librsvg
- libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )
+ libnotify? ( x11-libs/libnotify )
)
+ net-libs/libtorrent-rasterbar[python,${PYTHON_USEDEP}]
webinterface? ( dev-python/mako[${PYTHON_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.3-setup.py.patch"
+ "${FILESDIR}/${PN}-2.0.3-UI-status.patch"
+)
+
python_prepare_all() {
local args=(
-e "/Compiling po file/a \\\tuptoDate = False"
@@ -69,13 +70,6 @@ python_prepare_all() {
)
sed -i "${args[@]}" -- 'deluge/core/preferencesmanager.py' || die
- local loc_dir="${S}/deluge/i18n"
- l10n_find_plocales_changes "${loc_dir}" "" ".po"
- rm_loc() {
- rm -vf "${loc_dir}/${1}.po" || die
- }
- l10n_for_each_disabled_locale_do rm_loc
-
distutils-r1_python_prepare_all
}