summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-07-09 12:38:35 -0400
committerCraig Andrews <candrews@gentoo.org>2020-07-09 12:39:09 -0400
commita2cb8c69a7f234bf485399106ec2f565a3d402a0 (patch)
tree279d022a981f5739415f3cfd1b64e761dcb11688 /net-p2p/deluge
parentapp-text/calibre: Add patch for bug 731786 (diff)
downloadgentoo-a2cb8c69a7f234bf485399106ec2f565a3d402a0.tar.gz
gentoo-a2cb8c69a7f234bf485399106ec2f565a3d402a0.tar.bz2
gentoo-a2cb8c69a7f234bf485399106ec2f565a3d402a0.zip
net-p2p/deluge: Fix fails to load state saved by version 1.3.15-r3
Closes: https://bugs.gentoo.org/731664 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p/deluge')
-rw-r--r--net-p2p/deluge/deluge-2.0.3-r8.ebuild142
-rw-r--r--net-p2p/deluge/files/deluge-2.0.3-fix-pickle.patch143
2 files changed, 285 insertions, 0 deletions
diff --git a/net-p2p/deluge/deluge-2.0.3-r8.ebuild b/net-p2p/deluge/deluge-2.0.3-r8.ebuild
new file mode 100644
index 000000000000..8c09d112b658
--- /dev/null
+++ b/net-p2p/deluge/deluge-2.0.3-r8.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1 systemd
+
+DESCRIPTION="BitTorrent client with a client/server model"
+HOMEPAGE="https://deluge-torrent.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.deluge-torrent.org/${PN}"
+else
+ SRC_URI="http://download.deluge-torrent.org/source/2.0/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~sparc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="console geoip gtk libnotify sound webinterface"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ libnotify? ( gtk )
+ sound? ( gtk )
+"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ net-libs/libtorrent-rasterbar[python,${PYTHON_MULTI_USEDEP}]
+ dev-python/wheel[${PYTHON_MULTI_USEDEP}]
+ ')
+ dev-util/intltool
+ acct-group/deluge
+ acct-user/deluge"
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/distro[${PYTHON_MULTI_USEDEP}]
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ dev-python/rencode[${PYTHON_MULTI_USEDEP}]
+ dev-python/setproctitle[${PYTHON_MULTI_USEDEP}]
+ dev-python/six[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/twisted-17.1.0[crypt,${PYTHON_MULTI_USEDEP}]
+ >=dev-python/zope-interface-4.4.2[${PYTHON_MULTI_USEDEP}]
+ geoip? ( dev-python/geoip-python[${PYTHON_MULTI_USEDEP}] )
+ gtk? (
+ sound? ( dev-python/pygame[${PYTHON_MULTI_USEDEP}] )
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ gnome-base/librsvg
+ libnotify? ( x11-libs/libnotify )
+ )
+ net-libs/libtorrent-rasterbar[python,${PYTHON_MULTI_USEDEP}]
+ dev-python/mako[${PYTHON_MULTI_USEDEP}]
+ ')"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.3-setup.py.patch"
+ "${FILESDIR}/${PN}-2.0.3-UI-status.patch"
+ "${FILESDIR}/${PN}-2.0.3-gettext.patch"
+ "${FILESDIR}/${P}-fix-pickle.patch"
+)
+
+python_prepare_all() {
+ local args=(
+ -e "/Compiling po file/a \\\tuptoDate = False"
+ )
+ sed -i "${args[@]}" -- 'setup.py' || die
+ args=(
+ -e 's|"new_release_check": True|"new_release_check": False|'
+ -e 's|"check_new_releases": True|"check_new_releases": False|'
+ -e 's|"show_new_releases": True|"show_new_releases": False|'
+ )
+ sed -i "${args[@]}" -- 'deluge/core/preferencesmanager.py' || die
+
+ distutils-r1_python_prepare_all
+}
+
+esetup.py() {
+ # bug 531370: deluge has its own plugin system. No need to relocate its egg info files.
+ # Override this call from the distutils-r1 eclass.
+ # This does not respect the distutils-r1 API. DONOT copy this example.
+ set -- "${PYTHON}" setup.py "$@"
+ echo "$@"
+ "$@" || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if ! use console ; then
+ rm -r "${D}/$(python_get_sitedir)/deluge/ui/console/" || die
+ rm "${ED}/usr/bin/deluge-console" || die
+ rm "${ED}/usr/share/man/man1/deluge-console.1" ||die
+ fi
+ if ! use gtk ; then
+ rm -r "${D}/$(python_get_sitedir)/deluge/ui/gtk3/" || die
+ rm -r "${ED}/usr/share/icons/" || die
+ rm "${ED}/usr/bin/deluge-gtk" || die
+ rm "${ED}/usr/share/man/man1/deluge-gtk.1" || die
+ rm "${ED}/usr/share/applications/deluge.desktop" || die
+ fi
+ if use webinterface; then
+ newinitd "${FILESDIR}/deluge-web.init-2" deluge-web
+ newconfd "${FILESDIR}/deluge-web.conf" deluge-web
+ systemd_newunit "${FILESDIR}/deluge-web.service-3" deluge-web.service
+ systemd_install_serviced "${FILESDIR}/deluge-web.service.conf"
+ else
+ rm -r "${D}/$(python_get_sitedir)/deluge/ui/web/" || die
+ rm "${ED}/usr/bin/deluge-web" || die
+ rm "${ED}/usr/share/man/man1/deluge-web.1" || die
+ fi
+ newinitd "${FILESDIR}"/deluged.init-2 deluged
+ newconfd "${FILESDIR}"/deluged.conf-2 deluged
+ systemd_newunit "${FILESDIR}"/deluged.service-2 deluged.service
+ systemd_install_serviced "${FILESDIR}"/deluged.service.conf
+
+ python_optimize
+}
+
+pkg_postinst() {
+ elog
+ elog "If, after upgrading, deluge doesn't work, please remove the"
+ elog "'~/.config/deluge' directory and try again, but make a backup"
+ elog "first!"
+ elog
+ elog "To start the daemon either run 'deluged' as user"
+ elog "or modify /etc/conf.d/deluged and run"
+ elog "/etc/init.d/deluged start as root"
+ elog "You can still use deluge the old way"
+ elog
+ elog "Systemd unit files for deluged and deluge-web no longer source"
+ elog "/etc/conf.d/deluge* files. Environment variable customization now"
+ elog "happens in /etc/systemd/system/deluged.service.d/00gentoo.conf"
+ elog "and /etc/systemd/system/deluge-web.service.d/00gentoo.conf"
+ elog
+ elog "For more information look at https://dev.deluge-torrent.org/wiki/Faq"
+ elog
+}
diff --git a/net-p2p/deluge/files/deluge-2.0.3-fix-pickle.patch b/net-p2p/deluge/files/deluge-2.0.3-fix-pickle.patch
new file mode 100644
index 000000000000..446ae2e9a0e1
--- /dev/null
+++ b/net-p2p/deluge/files/deluge-2.0.3-fix-pickle.patch
@@ -0,0 +1,143 @@
+https://dev.deluge-torrent.org/changeset/23b3f144fce3424ae
+
+Index: deluge/core/torrentmanager.py
+===================================================================
+--- deluge-2.0.3/deluge/core/torrentmanager.py (revision 8b62e50eb8bf81a177c4d62484a44b766c6f54a6)
++++ deluge-2.0.3/deluge/core/torrentmanager.py (revision 23b3f144fce3424ae874d54a659cb7b8dd624ade)
+@@ -26,5 +26,5 @@
+ import deluge.component as component
+ from deluge._libtorrent import lt
+-from deluge.common import archive_files, decode_bytes, get_magnet_info, is_magnet
++from deluge.common import PY2, archive_files, decode_bytes, get_magnet_info, is_magnet
+ from deluge.configmanager import ConfigManager, get_config_dir
+ from deluge.core.authmanager import AUTH_LEVEL_ADMIN
+@@ -810,5 +810,8 @@
+ try:
+ with open(filepath, 'rb') as _file:
+- state = pickle.load(_file)
++ if PY2:
++ state = pickle.load(_file)
++ else:
++ state = pickle.load(_file, encoding='utf8')
+ except (IOError, EOFError, pickle.UnpicklingError) as ex:
+ message = 'Unable to load {}: {}'.format(filepath, ex)
+Index: deluge/tests/data/utf8_filename_torrents.state
+===================================================================
+--- deluge-2.0.3/deluge/tests/data/utf8_filename_torrents.state (revision 23b3f144fce3424ae874d54a659cb7b8dd624ade)
++++ deluge-2.0.3/deluge/tests/data/utf8_filename_torrents.state (revision 23b3f144fce3424ae874d54a659cb7b8dd624ade)
+@@ -0,0 +1,85 @@
++(ideluge.core.torrentmanager
++TorrentManagerState
++p1
++(dp2
++S'torrents'
++p3
++(lp4
++(ideluge.core.torrentmanager
++TorrentState
++p5
++(dp6
++S'max_download_speed'
++p7
++I-1
++sS'move_completed_path'
++p8
++S'/home/calum/Downloads'
++p9
++sS'paused'
++p10
++I00
++sS'max_upload_slots'
++p11
++I-1
++sS'prioritize_first_last'
++p12
++I00
++sS'max_connections'
++p13
++I-1
++sS'compact'
++p14
++I00
++sS'queue'
++p15
++I0
++sS'file_priorities'
++p16
++(lp17
++I4
++asS'filename'
++p18
++S'\xc2\xa2.torrent'
++p19
++sS'max_upload_speed'
++p20
++I-1
++sS'save_path'
++p21
++S'/home/calum/Downloads'
++p22
++sS'time_added'
++p23
++F1573563097.749759
++sS'total_uploaded'
++p24
++I0
++sS'torrent_id'
++p25
++S'80d81d55ef3b85f3c1b634c362e014b35594dc71'
++p26
++sS'auto_managed'
++p27
++I01
++sS'stop_at_ratio'
++p28
++I00
++sS'move_completed'
++p29
++I00
++sS'trackers'
++p30
++(lp31
++sS'magnet'
++p32
++NsS'remove_at_ratio'
++p33
++I00
++sS'stop_ratio'
++p34
++F2
++sS'is_finished'
++p35
++I00
++sbasb.
+Index: deluge/tests/test_torrentmanager.py
+===================================================================
+--- deluge-2.0.3/deluge/tests/test_torrentmanager.py (revision c6b6902e9f3e37f5b15184eb509b48b43817a331)
++++ deluge-2.0.3/deluge/tests/test_torrentmanager.py (revision 23b3f144fce3424ae874d54a659cb7b8dd624ade)
+@@ -8,4 +8,6 @@
+ from __future__ import unicode_literals
+
++import os
++import shutil
+ import warnings
+ from base64 import b64encode
+@@ -29,5 +31,5 @@
+ class TorrentmanagerTestCase(BaseTestCase):
+ def set_up(self):
+- common.set_tmp_config_dir()
++ self.config_dir = common.set_tmp_config_dir()
+ self.rpcserver = RPCServer(listen=False)
+ self.core = Core()
+@@ -119,2 +121,11 @@
+ InvalidTorrentError, self.tm.remove, 'torrentidthatdoesntexist'
+ )
++
++ def test_open_state_from_python2(self):
++ """Open a Python2 state with a UTF-8 encoded torrent filename."""
++ shutil.copy(
++ common.get_test_data_file('utf8_filename_torrents.state'),
++ os.path.join(self.config_dir, 'state', 'torrents.state'),
++ )
++ state = self.tm.open_state()
++ self.assertEqual(len(state.torrents), 1)