summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2017-01-03 23:24:44 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-01-04 00:03:16 +0100
commit6e43286ad7be865bb0af543d6732f43a840840ea (patch)
tree3d893ab5fb086f9d1361eaff8a8151f5f6098607 /net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild
parentapp-vim/curcmdmode: remove old. (diff)
downloadgentoo-6e43286ad7be865bb0af543d6732f43a840840ea.tar.gz
gentoo-6e43286ad7be865bb0af543d6732f43a840840ea.tar.bz2
gentoo-6e43286ad7be865bb0af543d6732f43a840840ea.zip
net-p2p/go-ethereum: version bump to 1.5.5.
Package-Manager: Portage-2.3.0, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3316
Diffstat (limited to 'net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild')
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild b/net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild
new file mode 100644
index 000000000000..98a08bddc241
--- /dev/null
+++ b/net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Official golang implementation of the Ethereum protocol"
+HOMEPAGE="https://github.com/ethereum/go-ethereum"
+SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="evm opencl"
+
+DEPEND="dev-lang/go:=
+ opencl? ( virtual/opencl )
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ use opencl && export GO_OPENCL=true
+
+ emake geth
+ use evm && emake evm
+}
+
+src_install() {
+ einstalldocs
+
+ dobin build/bin/geth
+ use evm && dobin build/bin/evm
+}