summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-p2p/linuxdcpp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-p2p/linuxdcpp')
-rw-r--r--net-p2p/linuxdcpp/Manifest1
-rw-r--r--net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild54
-rw-r--r--net-p2p/linuxdcpp/metadata.xml8
3 files changed, 63 insertions, 0 deletions
diff --git a/net-p2p/linuxdcpp/Manifest b/net-p2p/linuxdcpp/Manifest
new file mode 100644
index 000000000000..1dec68acefd6
--- /dev/null
+++ b/net-p2p/linuxdcpp/Manifest
@@ -0,0 +1 @@
+DIST linuxdcpp-1.0.3.tar.bz2 289891 SHA256 3b4eb6cf015f0fe8283508976b24dbb1cd4fb861116d4536f1055136c2442c71 SHA512 c0eb38b89b6a47a4a29ade90b3813e302b8c4dd8bea39770fce4e232ff17035ba355b36feb6b69195ba7c8448a69943ee61722e335ad514f426238fb8a089e79 WHIRLPOOL e6feb69c38020a13b2d37cc7dd51614946e2ba2642d7173e72d9d50af37cc510b8ac0f983c1bf68feab3e2d82027471ab8fc3beacbe96b680c87c889cdd88034
diff --git a/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild b/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..6ff5e9064e0d
--- /dev/null
+++ b/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+# TODO: This needs to use the escons eclass.
+inherit eutils multiprocessing
+
+DESCRIPTION="Direct connect client, looks and works like famous DC++"
+HOMEPAGE="https://launchpad.net/linuxdcpp"
+SRC_URI="http://launchpad.net/linuxdcpp/1.0/${PV}/+download/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=gnome-base/libglade-2.4:2.0
+ >=x11-libs/gtk+-2.6:2
+ app-arch/bzip2
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ media-libs/fontconfig
+ >=dev-util/scons-0.96
+ virtual/pkgconfig"
+
+src_prepare() {
+ # prevent scons installation of *txt files to wrong directory
+ sed -i 's/.*source = text_files.*//' SConstruct
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} debug=1"
+
+ scons ${myconf} -j$(makeopts_jobs) CXXFLAGS="${CXXFLAGS}" PREFIX=/usr || die "scons failed"
+}
+
+src_install() {
+ # linuxdcpp does not install docs according to gentoos naming scheme, so do it by hand
+ dodoc Readme.txt Changelog.txt Credits.txt
+ rm "${S}"/*.txt
+
+ scons install PREFIX="/usr" FAKE_ROOT="${D}" || die "scons install failed"
+
+ doicon pixmaps/${PN}.png
+ make_desktop_entry ${PN} ${PN}
+}
+
+pkg_postinst() {
+ elog
+ elog "After adding first directory to shares you might need to restart linuxdcpp."
+ elog
+}
diff --git a/net-p2p/linuxdcpp/metadata.xml b/net-p2p/linuxdcpp/metadata.xml
new file mode 100644
index 000000000000..a7223bf09a4e
--- /dev/null
+++ b/net-p2p/linuxdcpp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-p2p</herd>
+ <upstream>
+ <remote-id type="launchpad">linuxdcpp</remote-id>
+ </upstream>
+</pkgmetadata>