summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-09-19 21:33:19 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-09-19 21:33:43 +0300
commit0e5ba4b6c98e31694b39e3e10f69a1ad2fc04def (patch)
tree0978aa5e72f60c1b79f484ce5ab1cd3453e2047b /net-p2p/qbittorrent
parentnet-misc/youtube-dl: Old. (diff)
downloadgentoo-0e5ba4b6c98e31694b39e3e10f69a1ad2fc04def.tar.gz
gentoo-0e5ba4b6c98e31694b39e3e10f69a1ad2fc04def.tar.bz2
gentoo-0e5ba4b6c98e31694b39e3e10f69a1ad2fc04def.zip
net-p2p/qbittorrent: Version bump (v4.1.3)
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.1.3.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 3548714b95f2..60e8bf24feba 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1,2 +1,3 @@
DIST qbittorrent-4.1.1.tar.gz 7464014 BLAKE2B be005fbecd1d2c9ee977fbdc6782bbad9708e3c2c6d46deb5831ae4e7457954cb95ae87850b759e81e87e345ca682acfcd23684b7704c437c4261ebb5bb46f5d SHA512 700c084b97556ba85276b42e46f77d5f7896052ce02ba052cd4b3e6967c8a848c27bcf63a289bf8276b38841bb9a80b9ec16335c3feb30dce0851170f54d101e
DIST qbittorrent-4.1.2.tar.gz 7697135 BLAKE2B 13e9456fd43395d597156519bdd665db898d462761dc5fe5f92e40994e8d0e214b0a1f9d8d327d44f8deb287c646c7013c17099bca193d85d1a3b2d851ada976 SHA512 25293378693cec875d1b52ea5aca8087a0d31021e6fbb4bd31f05c6979e36a5dc03983f2007a067942e1e119878b94a9e2b9622f324c7592f6630dcfe008b757
+DIST qbittorrent-4.1.3.tar.gz 7268632 BLAKE2B 72388d1198dd9bdf4844c1769c7a7c8fe2fcf8213bc0442dc1900ec4b0968a5aa291b0fb35e3e89b7fa7395cc336c44a447ae6d4360504393a68343e5f10efff SHA512 ffacd3755c8f4487d13c339ff40f6e52765fad2e68f6ea2892ea58c9e702f591fd6aafda48ec4fc8b5fecfa81fd34e3a1d5b96676f76ae657b3420d080323c09
diff --git a/net-p2p/qbittorrent/qbittorrent-4.1.3.ebuild b/net-p2p/qbittorrent/qbittorrent-4.1.3.ebuild
new file mode 100644
index 000000000000..dba40dca433b
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.1.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop gnome2-utils xdg-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org
+ https://github.com/qbittorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S="${WORKDIR}/qBittorrent-release-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug webui +X"
+REQUIRED_USE="dbus? ( X )"
+
+RDEPEND="
+ >=dev-libs/boost-1.62.0-r1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5(+),X?]
+ dev-qt/qtxml:5
+ >=net-libs/libtorrent-rasterbar-1.0.6:0=
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+src_configure() {
+ econf --with-qtsingleapplication=system \
+ $(use_enable dbus qt-dbus) \
+ $(use_enable debug) \
+ $(use_enable webui) \
+ $(use_enable X gui)
+}
+
+src_install() {
+ emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
+ domenu dist/unix/qbittorrent.desktop
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}