summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-12-22 22:35:09 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-12-22 22:35:24 +1100
commita26240268a67413b8e858c4261573da86c9e8192 (patch)
treebdbdf2a37b300e79c5e0133a5e7738a3619a1e86 /net-p2p/qbittorrent
parentnet-p2p/qbittorrent: sync live ebuild with latest release (diff)
downloadgentoo-a26240268a67413b8e858c4261573da86c9e8192.tar.gz
gentoo-a26240268a67413b8e858c4261573da86c9e8192.tar.bz2
gentoo-a26240268a67413b8e858c4261573da86c9e8192.zip
net-p2p/qbittorrent: version bump 4.0.3
Closes: https://bugs.gentoo.org/641706 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index cb03e0fc9b86..321272a3d792 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -3,3 +3,4 @@ DIST qbittorrent-3.3.12-cmake-3.8.patch.gz 18330 BLAKE2B f361f62a13001cd22cb9e97
DIST qbittorrent-3.3.12.tar.xz 2989604 BLAKE2B c30fff7ee01a3e509a434dd6c537098f34825cb2bb5a50f1c118987639a9ebd509928e421a2940b53e55509e3f9e6d4372a9e561edeb341af2a49d11aa7ddb31 SHA512 537ded71c75b3ab3fe014d77b5c4f8069ebb7a1aa94b5190b16e9ee910bfb70d462e5a3a536ba9222a97d8cceac00af0d33a92b7414b17724694d364fc2374df
DIST qbittorrent-3.3.16.tar.xz 2961420 BLAKE2B 3704e6575b1a321e04b0b9c1feee9acaf2e0ab5e0815c2cbb496265c8407c5b27111265e929ea3a516cba20acacc3b954579b5904de3411ae81726f2461dfbe0 SHA512 518ddbf8e657b3549800b5587924a8a34826895183f199b79aac72de81e6b5c009cb3b8d4fbb19151da0d96c21eb1c2f05d6ed061608cc8f589ec6fe62ce8117
DIST qbittorrent-4.0.1.tar.xz 4256588 BLAKE2B 579e850c34c62f515807a3fb2619740442c275e9de74cd7338a9e2d72340c78a2b7f484a3ee911094cbb3b551d61a927be454466637eac2d2355e84ebec0dbd4 SHA512 76eae32ebe82953e3164a8a292132a33ccc93f5a33ce7e1ce3253f4697939b73d21e1823bada7d3b1fe7401538a7f407ebeb86c281a34e261aec0aa02d7bef80
+DIST qbittorrent-4.0.3.tar.xz 4274292 BLAKE2B c6f6a87d26f01db318ac021a8ab9f8d1ada2f7cb0d2819dfbd41e57ddbcda8a077161c78bcf8210e3571572872c13aa2255973e842c07b6b538d94ac2501c841 SHA512 d439e5428ff43ec9317bfa70b365a912a33fa12eeaad72c6916514e7b04509bf3d2e35ef9c07a36e42e7fc80f4e019f6a299fd2f93df9ec10af4a95257096ecd
diff --git a/net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild b/net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild
new file mode 100644
index 000000000000..24631e72b86e
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils xdg-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ MY_P=${P/_}
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S=${WORKDIR}/${MY_P}
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug webui +X"
+REQUIRED_USE="dbus? ( X )"
+
+RDEPEND="
+ >=dev-libs/boost-1.62.0-r1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5,X?]
+ dev-qt/qtxml:5
+ >=net-libs/libtorrent-rasterbar-1.0.6
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSTEM_QTSINGLEAPPLICATION=ON
+ -DDBUS=$(usex dbus)
+ -DGUI=$(usex X)
+ -DWEBUI=$(usex webui)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}