summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Shkardoon <ss23@ss23.geek.nz>2019-08-01 02:44:06 +1200
committerJason Zaman <perfinion@gentoo.org>2019-08-05 21:49:55 +0800
commit3aeebc3b9dbf73553ed3aadee067313177e500aa (patch)
treebebd5840b1f540485570d4f519efce87ecfec2c2 /net-p2p/rtorrent/rtorrent-0.9.8.ebuild
parentnet-libs/libtorrent: Add version 0.13.8 ebuild (diff)
downloadgentoo-3aeebc3b9dbf73553ed3aadee067313177e500aa.tar.gz
gentoo-3aeebc3b9dbf73553ed3aadee067313177e500aa.tar.bz2
gentoo-3aeebc3b9dbf73553ed3aadee067313177e500aa.zip
net-p2p/rtorrent: Add version 0.9.8
Also removes dependency on dev-libs/libsigc++ Closes: https://github.com/gentoo/gentoo/pull/12587 Bug: https://bugs.gentoo.org/687996 Signed-off-by: Stephen Shkardoon <ss23@ss23.geek.nz> Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'net-p2p/rtorrent/rtorrent-0.9.8.ebuild')
-rw-r--r--net-p2p/rtorrent/rtorrent-0.9.8.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/net-p2p/rtorrent/rtorrent-0.9.8.ebuild b/net-p2p/rtorrent/rtorrent-0.9.8.ebuild
new file mode 100644
index 000000000000..bd9462e4dd92
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.9.8.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools linux-info systemd
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="https://rakshasa.github.io/rtorrent/"
+SRC_URI="http://rtorrent.net/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="daemon debug selinux test xmlrpc"
+
+COMMON_DEPEND="~net-libs/libtorrent-0.13.${PV##*.}
+ >=net-misc/curl-7.19.1
+ sys-libs/ncurses:0=
+ xmlrpc? ( dev-libs/xmlrpc-c )"
+RDEPEND="${COMMON_DEPEND}
+ daemon? ( app-misc/screen )
+ selinux? ( sec-policy/selinux-rtorrent )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/cppunit
+ virtual/pkgconfig"
+
+DOCS=( doc/rtorrent.rc )
+
+pkg_setup() {
+ if ! linux_config_exists || ! linux_chkconfig_present IPV6; then
+ ewarn "rtorrent will not start without IPv6 support in your kernel"
+ ewarn "without further configuration. Please set bind=0.0.0.0 or"
+ ewarn "similar in your rtorrent.rc"
+ ewarn "Upstream bug: https://github.com/rakshasa/rtorrent/issues/732"
+ fi
+}
+
+src_prepare() {
+ default
+
+ # https://github.com/rakshasa/rtorrent/issues/332
+ cp "${FILESDIR}"/rtorrent.1 "${S}"/doc/ || die
+
+ eautoreconf
+}
+
+src_configure() {
+ default
+
+ # configure needs bash or script bombs out on some null shift, bug #291229
+ CONFIG_SHELL=${BASH} econf \
+ --disable-dependency-tracking \
+ $(use_enable debug) \
+ $(use_with xmlrpc xmlrpc-c)
+}
+
+src_install() {
+ default
+ doman doc/rtorrent.1
+
+ if use daemon; then
+ newinitd "${FILESDIR}/rtorrentd.init" rtorrentd
+ newconfd "${FILESDIR}/rtorrentd.conf" rtorrentd
+ systemd_newunit "${FILESDIR}/rtorrentd_at.service" "rtorrentd@.service"
+ fi
+}