summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-17 18:21:06 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-17 18:21:47 +0100
commit36df70d6d22b3fb3dcaebdf885feb63c5d09f266 (patch)
tree1eca091c68fea340cf5afaf6120a065893fa7152 /net-p2p/saku
parentnet-misc/icaclient: Fixed eula.txt issue (bug #607862). (diff)
downloadgentoo-36df70d6d22b3fb3dcaebdf885feb63c5d09f266.tar.gz
gentoo-36df70d6d22b3fb3dcaebdf885feb63c5d09f266.tar.bz2
gentoo-36df70d6d22b3fb3dcaebdf885feb63c5d09f266.zip
net-p2p/saku: distutils-r1, EAPI=6
Diffstat (limited to 'net-p2p/saku')
-rw-r--r--net-p2p/saku/saku-3.11.0-r2.ebuild (renamed from net-p2p/saku/saku-3.11.0-r1.ebuild)23
1 files changed, 12 insertions, 11 deletions
diff --git a/net-p2p/saku/saku-3.11.0-r1.ebuild b/net-p2p/saku/saku-3.11.0-r2.ebuild
index f04cbd8797d0..a92eee2ce807 100644
--- a/net-p2p/saku/saku-3.11.0-r1.ebuild
+++ b/net-p2p/saku/saku-3.11.0-r2.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=3
+EAPI=6
-PYTHON_DEPEND="2:2.5"
+PYTHON_COMPAT=( python2_7 )
-inherit distutils eutils user
+inherit distutils-r1 user
DESCRIPTION="a clone of P2P anonymous BBS shinGETsu"
HOMEPAGE="http://shingetsu.info/"
@@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-python/cheetah"
+DEPEND="dev-python/cheetah[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
pkg_setup() {
@@ -25,21 +25,22 @@ pkg_setup() {
enewuser saku -1 -1 /var/run/saku saku
}
-src_prepare() {
+python_prepare_all() {
sed -i -e "/^prefix/s:/usr:${EPREFIX}/usr:" file/saku.ini || die
sed -i -e "s:root/share/doc/saku/:root/share/doc/${PF}/:" setup.py || die
+
+ distutils-r1_python_prepare_all
}
-src_install() {
- distutils_src_install
+python_install_all() {
+ distutils-r1_python_install_all
- dodir /etc/saku
insinto /etc/saku
doins "${FILESDIR}"/saku.ini
doinitd "${FILESDIR}"/saku
diropts -o saku -g saku
- dodir /var/log/saku
- dodir /var/spool/saku
+ keepdir /var/log/saku
+ keepdir /var/spool/saku
}