summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-03-15 10:46:54 +0000
committerMarek Szuba <marecki@gentoo.org>2019-03-15 10:53:35 +0000
commitb67a7186692191fbee1b164af49fa66f04f3a785 (patch)
tree7b725bde63d2bc217abd0ee3916285943f7823bb /net-p2p/syncthing
parentnet-p2p/syncthing: remove old (diff)
downloadgentoo-b67a7186692191fbee1b164af49fa66f04f3a785.tar.gz
gentoo-b67a7186692191fbee1b164af49fa66f04f3a785.tar.bz2
gentoo-b67a7186692191fbee1b164af49fa66f04f3a785.zip
net-p2p/syncthing: reset xdg environment
Turns out go uses $XDG_CACHE_HOME to decide where to put the build cache. Make sure it, and to be on the safe side the rest of XDG environment as well, is reset before building Syncthing. We do not inherit xdg.eclass for this purpose because it introduces several dependencies we do not actually need. Closes: https://bugs.gentoo.org/679280 Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'net-p2p/syncthing')
-rw-r--r--net-p2p/syncthing/syncthing-1.0.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/net-p2p/syncthing/syncthing-1.0.1.ebuild b/net-p2p/syncthing/syncthing-1.0.1.ebuild
index e49e912c31e6..6a2795b2434b 100644
--- a/net-p2p/syncthing/syncthing-1.0.1.ebuild
+++ b/net-p2p/syncthing/syncthing-1.0.1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
EGO_PN="github.com/${PN}/${PN}"
-inherit golang-vcs-snapshot systemd user
+inherit golang-vcs-snapshot systemd user xdg-utils
DESCRIPTION="Open Source Continuous File Synchronization"
HOMEPAGE="https://syncthing.net"
@@ -35,6 +35,9 @@ pkg_setup() {
}
src_prepare() {
+ # Bug #679280
+ xdg_environment_reset
+
default
sed -i \
's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/strelaysrv|' \