summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmert3@posteo.net>2020-06-17 14:17:12 -0500
committerJoonas Niilola <juippis@gentoo.org>2020-06-29 09:08:56 +0300
commitb33ab4027efae1115964c3baed69c8759693eed0 (patch)
tree462aa36e8e05f20f8d66c17245510fd36e11ef1f /net-p2p/tremc/tremc-0.9.2.ebuild
parentsys-apps/x86info: bump for py3 (diff)
downloadgentoo-b33ab4027efae1115964c3baed69c8759693eed0.tar.gz
gentoo-b33ab4027efae1115964c3baed69c8759693eed0.tar.bz2
gentoo-b33ab4027efae1115964c3baed69c8759693eed0.zip
net-p2p/tremc: Add version 0.9.2
Closes: https://bugs.gentoo.org/728552 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: John Helmert III <jchelmert3@posteo.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-p2p/tremc/tremc-0.9.2.ebuild')
-rw-r--r--net-p2p/tremc/tremc-0.9.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-p2p/tremc/tremc-0.9.2.ebuild b/net-p2p/tremc/tremc-0.9.2.ebuild
new file mode 100644
index 000000000000..2c02ce97e8da
--- /dev/null
+++ b/net-p2p/tremc/tremc-0.9.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_REQ_USE="ncurses"
+inherit bash-completion-r1 eutils python-single-r1
+
+DESCRIPTION="Ncurses interface for the Transmission BitTorrent client"
+HOMEPAGE="https://github.com/tremc/tremc"
+SRC_URI="https://github.com/tremc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+# Specify a no-op src_compile so upstream's broken Makefile doesn't get used
+src_compile() {
+ :
+}
+
+src_install() {
+ python_doscript tremc
+ newbashcomp completion/bash/tremc.sh tremc
+ insinto /usr/share/zsh/site-functions
+ doins completion/zsh/_tremc
+ doman tremc.1
+ dodoc NEWS README.md
+}
+
+pkg_postinst() {
+ optfeature "GeoIP support" dev-python/geoip-python
+ optfeature "Extract ipv4 from ipv6 addresses" dev-python/ipy
+ optfeature "Clipboard support" dev-python/pyperclip
+}