summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThamognya Kodi <contact@thamognya.com>2022-03-21 10:37:19 +0700
committerSam James <sam@gentoo.org>2022-03-22 00:27:07 +0000
commit9f3294574f36c9f22f72f879f3a8b053f6e2abea (patch)
tree2979e4421849ce472dec045bcb352eec272aa808 /net-p2p
parentmail-client/alot: use PEP 517; avoid network access during build; sync live (diff)
downloadgentoo-9f3294574f36c9f22f72f879f3a8b053f6e2abea.tar.gz
gentoo-9f3294574f36c9f22f72f879f3a8b053f6e2abea.tar.bz2
gentoo-9f3294574f36c9f22f72f879f3a8b053f6e2abea.zip
net-p2p/qbittorrent: 4.4.1 version
Closes: https://bugs.gentoo.org/834949 Signed-off-by: Thamognya Kodi <contact@thamognya.com> Closes: https://github.com/gentoo/gentoo/pull/24690 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.4.1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 99209ca85e66..6a66a7d39dd6 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -6,3 +6,4 @@ DIST qbittorrent-4.3.7.tar.gz 8494224 BLAKE2B 68f402619069fea87c5120e97f381d589f
DIST qbittorrent-4.3.8.tar.gz 8506355 BLAKE2B e59be1556ad0be697e32d69d890115df6ce20a46f883a9060994558db02f06cf87fbf68a17e6317e1b5819af523281bdd8cfdcc8ae68a0d707a238023dcc7840 SHA512 bb03f27f0807dfac867ddf5a6fcec1687946068a7e7d88483f0ded34d7279aa0d3324fe25f23c22ce80ee98437d8914229c5969ea8849eed1d4ad68e031601e2
DIST qbittorrent-4.3.9.tar.gz 8510414 BLAKE2B de98aff6d81f43c3ad87f6c5f800a4488e18173fb96713d0a2420cf4d4708c9b1f2f54c8d0aa566e7738b4f94d192aad9f0196a05d43724582ef81833901727f SHA512 ec33f67895fbf47acc2f79d9c9e16db8b96c756cf493b76eb24b90e13a790a709104ea9aa378ee111d8c38b605bed5192b366d1917bbf160b21aa2ae3aacd2d1
DIST qbittorrent-4.4.0.tar.gz 9037875 BLAKE2B b3789151a0e8b75bebecd84edcb5d75a1cf82674a5984c0ac8bb85d73dc90285fc7109b11ba593cd721fc4a45e87a69e00e85a47d79ed87423e538f56f2334c8 SHA512 7b1d4d45884d90bec14a28f01c9bdab0c9e2af496ade219393f4ccb14b9bb2901fc043407186da0efa1176f7fc9d1b1478864588e3869e363eb0eb35e5fe5c3f
+DIST qbittorrent-4.4.1.tar.gz 9090594 BLAKE2B 1b0d4900352c069177913a2ef66bd986a45d13d52f191b824a4dbd38d84b037a7410a9c71cf487d537a5ce70b00e8f695c20acd85ede963731a84f39c9b8ee5c SHA512 155e0394e1599fbbae4b03fc39a13085eb4f797fdf7ff45d2c552c66cdb523e146b77da4fa0f14d6b5b64e3b56f9da7163fd544811a40a9a787848007bfbd0a6
diff --git a/net-p2p/qbittorrent/qbittorrent-4.4.1.ebuild b/net-p2p/qbittorrent/qbittorrent-4.4.1.ebuild
new file mode 100644
index 000000000000..d95a557bc835
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.4.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org
+ https://github.com/qbittorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ S="${WORKDIR}/qBittorrent-release-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug webui +X"
+REQUIRED_USE="dbus? ( X )"
+
+RDEPEND="
+ >=dev-libs/boost-1.62.0-r1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtxml:5
+ dev-qt/qtsql:5
+ >=net-libs/libtorrent-rasterbar-1.2.12:0=
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+src_configure() {
+ econf \
+ $(use_enable dbus qt-dbus) \
+ $(use_enable debug) \
+ $(use_enable webui) \
+ $(use_enable X gui)
+}
+
+src_install() {
+ emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}