summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-06-29 13:59:30 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-06-30 19:04:50 +0000
commitb6bb9153b3e53dcd804f1dda0114c62eb8fe9f69 (patch)
tree42518ef2a611eb0ea623a10adc6dafa1dd0e226a /net-p2p
parentnet-analyzer/wireshark: Drop color.h. (diff)
downloadgentoo-b6bb9153b3e53dcd804f1dda0114c62eb8fe9f69.tar.gz
gentoo-b6bb9153b3e53dcd804f1dda0114c62eb8fe9f69.tar.bz2
gentoo-b6bb9153b3e53dcd804f1dda0114c62eb8fe9f69.zip
net-p2p/airdcpp-webclient: bump to 1.0.6
Package-Manager: portage-2.3.0_rc1 Closes: https://github.com/gentoo/gentoo/pull/1793 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.6.ebuild62
-rw-r--r--net-p2p/airdcpp-webclient/metadata.xml1
3 files changed, 63 insertions, 1 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 9ff9a6af7b7b..b0afd8d26882 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,2 +1,3 @@
DIST airdcpp-webclient-1.0.3.tar.gz 706279 SHA256 97239cdb973fd892b01446766b78403852ad39ec44ed9e2b94bd3a4b5514b139 SHA512 8294889d89644476e99ffa6938a52b1f5e5659a2bb51fdd409f06b56295b6fd5788b79c8ab8491af0500331fc4d0bd782535b68778b914ebb841fa16bb47fb08 WHIRLPOOL a0644a6582a9c43621e8b31cc0ed8a100ab395da3b26a3287ec746ec1c58546d8d69e8e56f1b8c0eb0e53f4e5f369e1cfe758ed938f69d676b894ad052c263b7
DIST airdcpp-webclient-1.0.4.tar.gz 707036 SHA256 ca1bc6a8049f4dfc1d8b2d3ed3a850ea24c8b09445c53d30db9ccbf9dfcfdc49 SHA512 069ec359860b941ce18adb5883b80f75fba017367ea5901a10f08466788cde46aab019e9b275a9524b623a7e34de957e4087ebd891d3aee9cad55a5c1a47f95b WHIRLPOOL 4b4852bb162dd83fbd3ca809553122e105518decd3d2c2d870f23b0369238502e253ba232964dbc3ba0e174f9c8ff43be5abfb47f2b5214a6629e895242f4a1d
+DIST airdcpp-webclient-1.0.6.tar.gz 707741 SHA256 10d1303d23341411cab61981c7185fb962a00bec59e2273d08c2c6fe51601411 SHA512 d80f0640a16b2f98f1a193553bbb67763cb327b7db40757bca9368c1fe6a053ef897566db1b7ad4583a438db4e772f2e0cc85c1f795f453109a4ab5d52234350 WHIRLPOOL e1923723377c879958fd4410b03eb1b4ea1e18a468b485c609e4d7fd98479d6a26b958afcd21463913a846c2e3b53634da18aa20d50c08e308865aeedac50362
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.6.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.6.ebuild
new file mode 100644
index 000000000000..662ef58c608d
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils user
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost
+ dev-libs/geoip
+ dev-libs/leveldb
+ dev-libs/openssl:0=
+ net-libs/miniupnpc
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp )
+ tbb? ( dev-cpp/tbb )
+"
+DEPEND="
+ dev-lang/python:*
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+ cmake-utils_src_install
+}
+
+pkg_setup() {
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}
diff --git a/net-p2p/airdcpp-webclient/metadata.xml b/net-p2p/airdcpp-webclient/metadata.xml
index c8f06e0b207a..ca7220f262bf 100644
--- a/net-p2p/airdcpp-webclient/metadata.xml
+++ b/net-p2p/airdcpp-webclient/metadata.xml
@@ -4,7 +4,6 @@
<maintainer type="person">
<email>sautier.louis@gmail.com</email>
<name>Louis Sautier</name>
- <description>Proxied maintainer; set to assignee in all bugs</description>
</maintainer>
<maintainer type="project">
<email>proxy-maint@gentoo.org</email>