summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-10-19 20:27:15 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-10-19 20:27:51 +0300
commitd1fbdaa0025dff38a2c86e257cd5ee6b030d7cbf (patch)
treebe1067a2a564ff899726934a2cd45d1d6dacb603 /net-p2p
parentdev-python/urllib3: Bump to 1.25.11 (diff)
downloadgentoo-d1fbdaa0025dff38a2c86e257cd5ee6b030d7cbf.tar.gz
gentoo-d1fbdaa0025dff38a2c86e257cd5ee6b030d7cbf.tar.bz2
gentoo-d1fbdaa0025dff38a2c86e257cd5ee6b030d7cbf.zip
net-p2p/qbittorrent: Version bum (v4.3.0)
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.3.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 86091bf17af2..4838614d0a83 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1 +1,2 @@
DIST qbittorrent-4.2.5.tar.gz 7961612 BLAKE2B 61d2f2154a291a6d1ddab7d4775d4ac4d19f471dceb783cb7933015ed9159afdca4075f429891dbbd7249f09d910ef643d27da4c4b7307adbf29354222265027 SHA512 8808029bdb3a1638fcf792e92c36bd39889dbc2ceb26c8d45ff17b086bd076f0b3a8ed78dd6a1e3debd32e5b0ce212eea194ec601210ae29093cfb567eb4ca0f
+DIST qbittorrent-4.3.0.tar.gz 7752864 BLAKE2B 77f5f18f3a8d0f3f498fe0678e39b0ffac7809586ac8ea75754d2d224ccd98b517327fecff95c3cdb740335df926a53494f3362969627afb0ff9f4a759ad33ed SHA512 bea69b4cb8ac80b5d36c674e0f2687f07902fc93d55c9874b97932e62bcd1643f7bc35c021c62b458b7ef154f23374c0a79ebb37f32499ae1a6242e0c0b088bb
diff --git a/net-p2p/qbittorrent/qbittorrent-4.3.0.ebuild b/net-p2p/qbittorrent/qbittorrent-4.3.0.ebuild
new file mode 100644
index 000000000000..15913a17fc03
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.3.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org
+ https://github.com/qbittorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S="${WORKDIR}/qBittorrent-release-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug webui +X"
+REQUIRED_USE="dbus? ( X )"
+
+RDEPEND="
+ >=dev-libs/boost-1.62.0-r1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtxml:5
+ >=net-libs/libtorrent-rasterbar-1.2.0:0=
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+src_configure() {
+ econf \
+ $(use_enable dbus qt-dbus) \
+ $(use_enable debug) \
+ $(use_enable webui) \
+ $(use_enable X gui)
+}
+
+src_install() {
+ emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}