summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-05-22 09:28:04 -0400
committerCraig Andrews <candrews@gentoo.org>2019-05-22 09:29:51 -0400
commitd73fb2f359d693744ec7efe32ca35fbc5bf5107e (patch)
tree2da4c766f11a73f783ccfa67df6f5d9f808df7fd /net-p2p
parentdev-python/llvmlite: Bump to 0.29.0rc1 (diff)
downloadgentoo-d73fb2f359d693744ec7efe32ca35fbc5bf5107e.tar.gz
gentoo-d73fb2f359d693744ec7efe32ca35fbc5bf5107e.tar.bz2
gentoo-d73fb2f359d693744ec7efe32ca35fbc5bf5107e.zip
net-p2p/cpuminer-opt: 3.9.0.1 version bump
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.9.0.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 909943814532..378cab54ef84 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1,2 +1,3 @@
DIST cpuminer-opt-3.8.8.1.tar.gz 1709515 BLAKE2B cecf9f57093fd89cef459cdc0d591a5de4bb12126a931dd9bfee0fc9b08a7ec4b5bb087ad383f14492b3da3066bac695f0022e1dfc595c7e331c9517b4b44db6 SHA512 5dd254237231abb84312c31be97952d1e1f1cd6c4fa0efc409581afb1a28d9783816b9efdb07501d67b99b831bce0a290e5cc2b3ce6c915a3e76b00edd582560
+DIST cpuminer-opt-3.9.0.1.tar.gz 1744675 BLAKE2B e1dff3bafd1c60bd67dbeca6acad4ee48a00bf0d77512686ac5b2bd9f375eee4a6e9b32c891f195bb98c4a48ac0f52a6da91bc51e28017dd811bf975d8c0550f SHA512 f807f9f7416983363116a07b12a191227907e26a658f6cd00f5556292785c27f6b56df9998a06bc1e44769bd549a5be75acd6986d446dd885b8b49763fde1731
DIST cpuminer-opt-3.9.0.tar.gz 1744113 BLAKE2B 0fef9ead2218284032d70df4d823f43896a72a06c91612b3a9981a89bb51c890d3fe54707af80d2ebe3ceb513ef98c3e7b036b9ec0a9767ff5b969bed2a26318 SHA512 beb3faf8f2b765f7f995274e247b59590c3cebf2f6d46ce39abac8ecec322cabfc4b2acc087686f9c701c2c32d96b5d1f95d34413ec70c727b58f67054fc2603
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.9.0.1.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.9.0.1.ebuild
new file mode 100644
index 000000000000..666d27ee1c02
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.9.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}