summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-10-03 14:26:23 -0400
committerMike Gilbert <floppym@gentoo.org>2015-10-03 14:26:34 -0400
commite4769ff5d04952e4c8fbe125212823d5726ee2d3 (patch)
treeebf4945aae9480669a2c19e8b24a2ef831cf62ad /net-p2p
parentdev-libs/ppl: 1.1 stable for ppc and ppc64. bug #562068. (diff)
downloadgentoo-e4769ff5d04952e4c8fbe125212823d5726ee2d3.tar.gz
gentoo-e4769ff5d04952e4c8fbe125212823d5726ee2d3.tar.bz2
gentoo-e4769ff5d04952e4c8fbe125212823d5726ee2d3.zip
net-p2p/transmission: Fix build with miniupnpc API 14
Thanks to Sander Sweers for the patch. Bug: https://bugs.gentoo.org/562020 Package-Manager: portage-2.2.22_p5
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission/files/2.84-miniupnp14.patch23
-rw-r--r--net-p2p/transmission/transmission-2.84-r1.ebuild2
-rw-r--r--net-p2p/transmission/transmission-2.84.ebuild4
3 files changed, 28 insertions, 1 deletions
diff --git a/net-p2p/transmission/files/2.84-miniupnp14.patch b/net-p2p/transmission/files/2.84-miniupnp14.patch
new file mode 100644
index 000000000000..7e531ccff69e
--- /dev/null
+++ b/net-p2p/transmission/files/2.84-miniupnp14.patch
@@ -0,0 +1,23 @@
+libtransmission: Build fix for miniupnp API version 14
+
+Patch by Sander Sweers <Sander.Sweers@gmail.com>
+
+Bug: https://bugs.gentoo.org/562020
+Index: libtransmission/upnp.c
+===================================================================
+--- libtransmission/upnp.c (revision 14564)
++++ libtransmission/upnp.c (working copy)
+@@ -86,8 +86,12 @@
+ struct UPNPDev * ret;
+ bool have_err;
+
+-#if (MINIUPNPC_API_VERSION >= 8) /* adds ipv6 and error args */
++#if (MINIUPNPC_API_VERSION >= 14) /* adds ttl */
+ int err = UPNPDISCOVER_SUCCESS;
++ ret = upnpDiscover (msec, NULL, NULL, 0, 0, 2, &err);
++ have_err = err != UPNPDISCOVER_SUCCESS;
++#elif (MINIUPNPC_API_VERSION >= 8) /* adds ipv6 and error args */
++ int err = UPNPDISCOVER_SUCCESS;
+ ret = upnpDiscover (msec, NULL, NULL, 0, 0, &err);
+ have_err = err != UPNPDISCOVER_SUCCESS;
+ #else
diff --git a/net-p2p/transmission/transmission-2.84-r1.ebuild b/net-p2p/transmission/transmission-2.84-r1.ebuild
index 9cbecb41267b..97a3a72001eb 100644
--- a/net-p2p/transmission/transmission-2.84-r1.ebuild
+++ b/net-p2p/transmission/transmission-2.84-r1.ebuild
@@ -72,6 +72,8 @@ src_prepare() {
# http://trac.transmissionbt.com/ticket/5700
sed -i -e '1iQMAKE_CXXFLAGS += -std=c++11' qt/qtr.pro || die
+ epatch "${FILESDIR}/2.84-miniupnp14.patch"
+
epatch_user
eautoreconf
}
diff --git a/net-p2p/transmission/transmission-2.84.ebuild b/net-p2p/transmission/transmission-2.84.ebuild
index 8af517cf0491..d1648c448a79 100644
--- a/net-p2p/transmission/transmission-2.84.ebuild
+++ b/net-p2p/transmission/transmission-2.84.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -65,6 +65,8 @@ src_prepare() {
# http://trac.transmissionbt.com/ticket/5700
sed -i -e '1iQMAKE_CXXFLAGS += -std=c++11' qt/qtr.pro || die
+ epatch "${FILESDIR}/2.84-miniupnp14.patch"
+
epatch_user
eautoreconf
}