summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-print/dymo-cups-drivers/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-print/dymo-cups-drivers/files')
-rw-r--r--net-print/dymo-cups-drivers/files/dymo-cups-drivers-1.2.0+gcc-4.6.patch48
-rw-r--r--net-print/dymo-cups-drivers/files/dymo-cups-drivers-1.2.0-cxxflags.patch15
2 files changed, 63 insertions, 0 deletions
diff --git a/net-print/dymo-cups-drivers/files/dymo-cups-drivers-1.2.0+gcc-4.6.patch b/net-print/dymo-cups-drivers/files/dymo-cups-drivers-1.2.0+gcc-4.6.patch
new file mode 100644
index 000000000000..3f60290af837
--- /dev/null
+++ b/net-print/dymo-cups-drivers/files/dymo-cups-drivers-1.2.0+gcc-4.6.patch
@@ -0,0 +1,48 @@
+Index: dymo-cups-drivers-1.2.0/src/common/Halftoning.h
+===================================================================
+--- dymo-cups-drivers-1.2.0.orig/src/common/Halftoning.h
++++ dymo-cups-drivers-1.2.0/src/common/Halftoning.h
+@@ -22,6 +22,7 @@
+ #ifndef h4D098F6A_47C6_4e9d_BD74_2DC6034F8EEF
+ #define h4D098F6A_47C6_4e9d_BD74_2DC6034F8EEF
+
++#include <cstdlib>
+ #include "CommonTypedefs.h"
+
+ //namespace dymo
+Index: dymo-cups-drivers-1.2.0/src/lw/LabelWriterDriver.h
+===================================================================
+--- dymo-cups-drivers-1.2.0.orig/src/lw/LabelWriterDriver.h
++++ dymo-cups-drivers-1.2.0/src/lw/LabelWriterDriver.h
+@@ -21,6 +21,7 @@
+ #ifndef h53a93353_4968_443a_a5aa_1167526295fc
+ #define h53a93353_4968_443a_a5aa_1167526295fc
+
++#include <cstdlib>
+ #include "PrinterDriver.h"
+
+ namespace DymoPrinterDriver
+Index: dymo-cups-drivers-1.2.0/src/lw/tests/MOCK_LWLMPrintEnvironment.h
+===================================================================
+--- dymo-cups-drivers-1.2.0.orig/src/lw/tests/MOCK_LWLMPrintEnvironment.h
++++ dymo-cups-drivers-1.2.0/src/lw/tests/MOCK_LWLMPrintEnvironment.h
+@@ -21,6 +21,7 @@
+ #ifndef hc8e31bb3_01a5_4422_84b8_64c017e18521
+ #define hc8e31bb3_01a5_4422_84b8_64c017e18521
+
++#include <cstdlib>
+ #include "../PrinterDriver.h"
+ #include "MOCK_PrintEnvironment.h"
+
+Index: dymo-cups-drivers-1.2.0/src/lw/tests/MOCK_LWLMPrintEnvironment.cpp
+===================================================================
+--- dymo-cups-drivers-1.2.0.orig/src/lw/tests/MOCK_LWLMPrintEnvironment.cpp
++++ dymo-cups-drivers-1.2.0/src/lw/tests/MOCK_LWLMPrintEnvironment.cpp
+@@ -20,6 +20,7 @@
+
+ #include "MOCK_LWLMPrintEnvironment.h"
+ #include "../LabelWriterDriver.h"
++#include <cassert>
+
+ static const byte TOF_BIT = 0x02;
+ static const byte ROLL_CHANGED_BIT = 0x08;
diff --git a/net-print/dymo-cups-drivers/files/dymo-cups-drivers-1.2.0-cxxflags.patch b/net-print/dymo-cups-drivers/files/dymo-cups-drivers-1.2.0-cxxflags.patch
new file mode 100644
index 000000000000..03d233acb1e2
--- /dev/null
+++ b/net-print/dymo-cups-drivers/files/dymo-cups-drivers-1.2.0-cxxflags.patch
@@ -0,0 +1,15 @@
+Index: dymo-cups-drivers-1.2.0/configure.ac
+===================================================================
+--- dymo-cups-drivers-1.2.0.orig/configure.ac
++++ dymo-cups-drivers-1.2.0/configure.ac
+@@ -87,9 +87,7 @@ AM_CONDITIONAL([SAMPLES], [test x$sample
+ AC_SUBST(cups_cflags)
+
+ warning_flags="-Wall -Wno-unknown-pragmas"
+-debug_flags=""
+-optimization_flags="-O2"
+-CXXFLAGS="${optimization_flags} ${warning_flags} ${debug_flags} ${cups_cflags}"
++CXXFLAGS="${CXXFLAGS} ${warning_flags} ${debug_flags} ${cups_cflags}"
+
+
+ AC_CHECK_LIB(cups, cupsMarkOptions, , AC_ERROR([Can't find cups library]))