summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-print/foo2zjs/foo2zjs-99999999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-print/foo2zjs/foo2zjs-99999999.ebuild')
-rw-r--r--net-print/foo2zjs/foo2zjs-99999999.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/net-print/foo2zjs/foo2zjs-99999999.ebuild b/net-print/foo2zjs/foo2zjs-99999999.ebuild
new file mode 100644
index 000000000000..11eaf26946fe
--- /dev/null
+++ b/net-print/foo2zjs/foo2zjs-99999999.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Support for printing to ZjStream-based printers"
+HOMEPAGE="http://foo2zjs.rkkda.com/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RESTRICT="bindist"
+
+RDEPEND="net-print/cups
+ net-print/foomatic-db-engine
+ || ( >=net-print/cups-filters-1.0.43-r1[foomatic] net-print/foomatic-filters )
+ virtual/udev"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ app-editors/vim
+ net-misc/wget
+ sys-apps/ed
+ sys-devel/bc
+ test? ( sys-process/time )"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ einfo "Fetching ${PN} tarball"
+ wget "http://foo2zjs.rkkda.com/${PN}.tar.gz"
+ tar zxf "${WORKDIR}/${PN}.tar.gz"
+
+ epatch "${FILESDIR}/${PN}-udev.patch"
+ epatch "${FILESDIR}/${PN}-usbbackend.patch"
+
+ cd "${S}"
+
+ einfo "Fetching additional files (firmware, etc)"
+ emake getweb
+
+ # Display wget output, downloading takes some time.
+ sed -e '/^WGETOPTS/s/-q//g' -i getweb
+
+ ./getweb all
+}
+
+src_prepare() {
+ # Prevent an access violation.
+ sed -e "s~/etc~${D}/etc~g" -i Makefile
+ sed -e "s~/etc~${D}/etc~g" -i hplj1000
+
+ # Prevent an access violation, do not create symlinks on live file system
+ # during installation.
+ sed -e 's/ install-filter / /g' -i Makefile
+
+ # Prevent an access violation, do not remove files from live filesystem
+ # during make install
+ sed -e '/rm .*LIBUDEVDIR)\//d' -i Makefile
+ sed -e '/rm .*lib\/udev\/rules.d\//d' -i hplj1000
+}
+
+src_compile() {
+ MAKEOPTS=-j1 default
+}
+
+src_install() {
+ # ppd files are installed automagically. We have to create a directory
+ # for them.
+ mkdir -p "${D}/usr/share/ppd"
+
+ emake DESTDIR="${D}" -j1 install install-hotplug
+}