summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-02-21 12:19:33 -0500
committerRick Farina <zerochaos@gentoo.org>2020-02-21 12:19:43 -0500
commit99af30bdb87c3935c1f1a007fd439cb697f5bf95 (patch)
tree4bfcbc782f62ef01aa538486ff9bdc1b2dc8cea6 /net-print/foo2zjs
parentmail-client/thunderbird: security cleanup (bug #709350) (diff)
downloadgentoo-99af30bdb87c3935c1f1a007fd439cb697f5bf95.tar.gz
gentoo-99af30bdb87c3935c1f1a007fd439cb697f5bf95.tar.bz2
gentoo-99af30bdb87c3935c1f1a007fd439cb697f5bf95.zip
net-print/foo2zjs: add stable candidate
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-print/foo2zjs')
-rw-r--r--net-print/foo2zjs/Manifest1
-rw-r--r--net-print/foo2zjs/foo2zjs-20200221.ebuild67
-rw-r--r--net-print/foo2zjs/foo2zjs-99999999.ebuild8
3 files changed, 73 insertions, 3 deletions
diff --git a/net-print/foo2zjs/Manifest b/net-print/foo2zjs/Manifest
new file mode 100644
index 000000000000..1a03fc0a7449
--- /dev/null
+++ b/net-print/foo2zjs/Manifest
@@ -0,0 +1 @@
+DIST foo2zjs-20200221.tar.xz 6330264 BLAKE2B 71e290cbb76d4975d72627270406a8479437adc3e94d334827d5c219dc0269708ddc559f847f881076f40515396931a2b4a4f4604b121e6a7007a5b2fc5b3432 SHA512 8d992b48157189b800a2ba2f8e528f0c3d59a532e6172f2979c4b3f6fa9a3ac7167e0e28195019b70e260d2459ebd17aba118735d5a2c8e5c7603c750ea8dfaf
diff --git a/net-print/foo2zjs/foo2zjs-20200221.ebuild b/net-print/foo2zjs/foo2zjs-20200221.ebuild
new file mode 100644
index 000000000000..a3a8fb5c6d12
--- /dev/null
+++ b/net-print/foo2zjs/foo2zjs-20200221.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Support for printing to ZjStream-based printers"
+HOMEPAGE="http://foo2zjs.rkkda.com/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RESTRICT="bindist !test? ( test )"
+
+RDEPEND="net-print/cups
+ net-print/foomatic-db-engine
+ >=net-print/cups-filters-1.0.43-r1[foomatic]
+ virtual/udev"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ app-editors/vim
+ net-misc/wget
+ sys-apps/ed
+ sys-devel/bc
+ test? ( sys-process/time )"
+
+SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-udev.patch"\
+ "${FILESDIR}/${PN}-usbbackend.patch"
+
+ # Prevent an access violation.
+ sed -e "s~/etc~${D}/etc~g" -i Makefile || die
+ sed -e "s~/etc~${D}/etc~g" -i hplj1000 || die
+
+ # Prevent an access violation, do not create symlinks on live file system
+ # during installation.
+ sed -e 's/ install-filter / /g' -i Makefile || die
+
+ # Prevent an access violation, do not remove files from live filesystem
+ # during make install
+ sed -e '/rm .*LIBUDEVDIR)\//d' -i Makefile || die
+ sed -e '/rm .*lib\/udev\/rules.d\//d' -i hplj1000 || die
+
+ default
+}
+
+src_compile() {
+ MAKEOPTS=-j1 CC="$(tc-getCC)" default
+}
+
+src_install() {
+ # ppd files are installed automagically. We have to create a directory
+ # for them.
+ dodir /usr/share/ppd
+
+ emake DESTDIR="${D}" -j1 install install-hotplug
+}
+
+src_test() {
+ # see bug 419787
+ : ;
+}
diff --git a/net-print/foo2zjs/foo2zjs-99999999.ebuild b/net-print/foo2zjs/foo2zjs-99999999.ebuild
index 53f4e1dcf6aa..630ce3d9e595 100644
--- a/net-print/foo2zjs/foo2zjs-99999999.ebuild
+++ b/net-print/foo2zjs/foo2zjs-99999999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs eutils
@@ -34,7 +34,7 @@ src_unpack() {
wget "http://foo2zjs.rkkda.com/${PN}.tar.gz" || die
tar zxf "${WORKDIR}/${PN}.tar.gz" || die
- epatch "${FILESDIR}/${PN}-udev.patch"\
+ eapply "${FILESDIR}/${PN}-udev.patch"\
"${FILESDIR}/${PN}-usbbackend.patch"
cd "${S}" || die
@@ -61,6 +61,8 @@ src_prepare() {
# during make install
sed -e '/rm .*LIBUDEVDIR)\//d' -i Makefile || die
sed -e '/rm .*lib\/udev\/rules.d\//d' -i hplj1000 || die
+
+ default
}
src_compile() {