summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Norris <briannorris@chromium.org>2016-01-19 15:09:31 -0500
committerMike Frysinger <vapier@gentoo.org>2016-01-19 15:10:29 -0500
commit0df2c1ffc08a1cc7089b9ca7abfffd7d2b6d45e9 (patch)
treeb24d7ab6688b7bf40f0c2087a314245dd1b26512 /net-print/foomatic-db-engine/foomatic-db-engine-4.0.12.ebuild
parentnet-print/foomatic-db-engine: switch to `default` (diff)
downloadgentoo-0df2c1ffc08a1cc7089b9ca7abfffd7d2b6d45e9.tar.gz
gentoo-0df2c1ffc08a1cc7089b9ca7abfffd7d2b6d45e9.tar.bz2
gentoo-0df2c1ffc08a1cc7089b9ca7abfffd7d2b6d45e9.zip
net-print/foomatic-db-engine: use pkg-config to locate libxml2 libs
This fixes up cross-compiling issues by utilizing standard pkg-config files to locate libxml2 settings rather than `libxml2-config`.
Diffstat (limited to 'net-print/foomatic-db-engine/foomatic-db-engine-4.0.12.ebuild')
-rw-r--r--net-print/foomatic-db-engine/foomatic-db-engine-4.0.12.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-print/foomatic-db-engine/foomatic-db-engine-4.0.12.ebuild b/net-print/foomatic-db-engine/foomatic-db-engine-4.0.12.ebuild
index 74a50f5fc1dd..120d1c96d38e 100644
--- a/net-print/foomatic-db-engine/foomatic-db-engine-4.0.12.ebuild
+++ b/net-print/foomatic-db-engine/foomatic-db-engine-4.0.12.ebuild
@@ -5,7 +5,7 @@
EAPI=5
GENTOO_DEPEND_ON_PERL_SUBSLOT=yes
-inherit eutils perl-app versionator
+inherit eutils perl-app versionator autotools
DESCRIPTION="Generates ppds out of xml foomatic printer description files"
HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
@@ -16,7 +16,8 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE=""
-DEPEND="net-print/cups"
+DEPEND="net-print/cups
+ virtual/pkgconfig"
RDEPEND="
dev-libs/libxml2
|| ( >=net-print/cups-filters-1.0.43-r1[foomatic] net-print/foomatic-filters )
@@ -26,8 +27,10 @@ PDEPEND="net-print/foomatic-db"
src_prepare() {
epatch \
"${FILESDIR}"/4.0.7-perl-module.patch \
- "${FILESDIR}"/4.0.7-respect-ldflag.patch
+ "${FILESDIR}"/4.0.7-respect-ldflag.patch \
+ "${FILESDIR}"/4.0.12-use-pkgconfig.patch
sed -i -e "s:@LIB_CUPS@:$(cups-config --serverbin):" Makefile.in || die
+ eautoreconf
}
src_configure() {