summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-print/npadmin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-print/npadmin')
-rw-r--r--net-print/npadmin/Manifest1
-rw-r--r--net-print/npadmin/files/npadmin-0.8.7-stdlib.patch10
-rw-r--r--net-print/npadmin/metadata.xml8
-rw-r--r--net-print/npadmin/npadmin-0.8.7.ebuild30
4 files changed, 49 insertions, 0 deletions
diff --git a/net-print/npadmin/Manifest b/net-print/npadmin/Manifest
new file mode 100644
index 000000000000..fb3363e38068
--- /dev/null
+++ b/net-print/npadmin/Manifest
@@ -0,0 +1 @@
+DIST npadmin-0.8.7.tar.gz 104209 SHA256 829056157c5244e200af96d323fc2436bff53d353c671de8b1e7d7e0bca5ee1b
diff --git a/net-print/npadmin/files/npadmin-0.8.7-stdlib.patch b/net-print/npadmin/files/npadmin-0.8.7-stdlib.patch
new file mode 100644
index 000000000000..976cc9c191a2
--- /dev/null
+++ b/net-print/npadmin/files/npadmin-0.8.7-stdlib.patch
@@ -0,0 +1,10 @@
+--- npadmin-0.8.7/snmpsock.h 1998-12-31 04:04:42.000000000 +0100
++++ npadmin-0.8.7-patched/snmpsock.h 2005-02-23 15:37:41.082565000 +0100
+@@ -2,6 +2,7 @@
+ #define __SNMPSOCK_H_
+
+ #include <pthread.h>
++#include <stdlib.h>
+
+ class SNMP_socket {
+ int sock;
diff --git a/net-print/npadmin/metadata.xml b/net-print/npadmin/metadata.xml
new file mode 100644
index 000000000000..911d11367046
--- /dev/null
+++ b/net-print/npadmin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>printing</herd>
+ <upstream>
+ <remote-id type="sourceforge">npadmin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-print/npadmin/npadmin-0.8.7.ebuild b/net-print/npadmin/npadmin-0.8.7.ebuild
new file mode 100644
index 000000000000..0518079540fc
--- /dev/null
+++ b/net-print/npadmin/npadmin-0.8.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+DESCRIPTION="Network printer command-line adminstration tool"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://npadmin.sourceforge.net/"
+# this does NOT link against SNMP
+DEPEND=""
+KEYWORDS="x86 ~amd64 ~ppc"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${P}-stdlib.patch
+}
+
+src_compile() {
+ econf || die
+ emake || die "Make failed."
+}
+
+src_install() {
+ dobin npadmin
+ doman npadmin.1
+ dodoc README AUTHORS ChangeLog INSTALL NEWS README TODO
+}