summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-12-15 21:03:20 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-12-15 21:03:20 +0100
commit23476f9dfe4a5d3c52331a1f07b42188c612c9b5 (patch)
tree3ffe96cb5b4129c9585fd6a77d39eb49cad6360d /net-print
parentnet-misc/curl: add mbedtls support (diff)
downloadgentoo-23476f9dfe4a5d3c52331a1f07b42188c612c9b5.tar.gz
gentoo-23476f9dfe4a5d3c52331a1f07b42188c612c9b5.tar.bz2
gentoo-23476f9dfe4a5d3c52331a1f07b42188c612c9b5.zip
net-print/cups-filters: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups-filters/Manifest1
-rw-r--r--net-print/cups-filters/cups-filters-1.4.0.ebuild122
2 files changed, 123 insertions, 0 deletions
diff --git a/net-print/cups-filters/Manifest b/net-print/cups-filters/Manifest
index a8d4281eeca1..91a3dba99e75 100644
--- a/net-print/cups-filters/Manifest
+++ b/net-print/cups-filters/Manifest
@@ -1,3 +1,4 @@
DIST cups-filters-1.0.71.tar.xz 1339116 SHA256 3180aa209c383402822e568ccef8e1ca43f51e30b3af2039c34ebae919a69c1f SHA512 dc243e88d535c8d7e7fd53074b1093a46fc22742504efa09096d2b216846df875e4d914f25d2f726034692538cfdf1b713bc1ef44d199003a21e242b99f44a01 WHIRLPOOL 4afc7079594563f57af81501192cc0cba19db6cd5c10a9544339858a343e245b485e528fbf80eecd711341b23b8321bde817c49db7ddd2f0b801da2b4b9c580d
DIST cups-filters-1.2.0.tar.xz 1357268 SHA256 31dcb71dc79129056a5b0f6d30880bdb6511ee7acd06a3f5bd4e9d2684801d62 SHA512 1389d45607bee8376f23efc9b723df276002bf47292670e6cc872a8896ffe06d9eb0aa6f2be0c8c0ad86c8831bcc8f3779baa78d52224fb17dc2bf4ce9a97ca2 WHIRLPOOL 40b75a8ea04774f264691b85065a05296653c2c8e1de4b459a1ae995b4ea23ddbdd0b2e5ae7ab651f7486962507eb64f211034c6f8f24a958af15c794e12afc5
DIST cups-filters-1.3.0.tar.xz 1362904 SHA256 61b669809dda352a427546e09de5a68a3d960c7646ef5c590772d4aa1b445995 SHA512 3bff2a836be4f2722e2c06ea1ef8faf994c38eba244482cd1b84c33cef4d156e41470a4c7feda31c96ab01fc3872fcbba411ed4ce71fa4b57e817336d7e11888 WHIRLPOOL 156bbf35c129f64ab3900add54ff89c80ddce1b9bb18d5a66ef8b20b2d2c0243d4ba623fa398c812def575cf27f131e5f228e697f964543e9190f36b3e31dd9d
+DIST cups-filters-1.4.0.tar.xz 1373724 SHA256 0aa63f82a3feb5c46136b917722ee1565b4c1e2e533db4716f62d31e29c6579a SHA512 c1f8b45ef79747405cbe114fc35f14cf30d3a7f13753bbfb524cb2ce7c7e4f10a4af8cd1df978a231c119d0e893efed946b25183f8898253b5be72ed9c926963 WHIRLPOOL ebce525e81f2ce6b040b154111e71df49f341337073795a156ac20b502352f2711034a651e1910cde7266de2177f02dabcf9efd86ab1d2afc57140dd4a697d9e
diff --git a/net-print/cups-filters/cups-filters-1.4.0.ebuild b/net-print/cups-filters/cups-filters-1.4.0.ebuild
new file mode 100644
index 000000000000..52f9132f487a
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-1.4.0.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit base eutils perl-module autotools systemd
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit bzr
+ EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
+ KEYWORDS="~arm64"
+else
+ SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~m68k-mint"
+fi
+DESCRIPTION="Cups PDF filters"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdfasstandardprintjobformat"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic jpeg perl png static-libs tiff zeroconf"
+
+RDEPEND="
+ >=app-text/ghostscript-gpl-9.09
+ app-text/poppler:=[cxx,jpeg?,lcms,tiff?,xpdf-headers(+)]
+ >=app-text/qpdf-3.0.2:=
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/lcms:2
+ >=net-print/cups-1.7.3
+ !<=net-print/cups-1.5.9999
+ sys-devel/bc
+ sys-libs/zlib
+ dbus? ( sys-apps/dbus )
+ foomatic? ( !net-print/foomatic-filters )
+ jpeg? ( virtual/jpeg:0 )
+ perl? ( dev-lang/perl:= )
+ png? ( media-libs/libpng:0= )
+ tiff? ( media-libs/tiff:0 )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+"
+
+src_prepare() {
+ base_src_prepare
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable dbus) \
+ $(use_enable zeroconf avahi) \
+ $(use_enable static-libs static) \
+ --with-fontdir="fonts/conf.avail" \
+ --with-pdftops=pdftops \
+ --enable-imagefilters \
+ $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with tiff) \
+ --with-rcdir=no \
+ --with-browseremoteprotocols=DNSSD,CUPS \
+ --without-php
+}
+
+src_compile() {
+ MAKEOPTS=-j1 default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_configure
+ perl-module_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_install
+ perl_delete_localpod
+ popd > /dev/null
+ fi
+
+ # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+ dosym /usr/libexec/cups/filter/gstoraster /usr/libexec/cups/filter/pstoraster
+ dosym /usr/libexec/cups/filter/gstopxl /usr/libexec/cups/filter/pstopxl
+
+ prune_libtool_files --all
+
+ cp "${FILESDIR}"/cups-browsed.init.d "${T}"/cups-browsed || die
+
+ if ! use zeroconf ; then
+ sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+ sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+ fi
+
+ if ! use foomatic ; then
+ # this needs an upstream solution / configure switch
+ rm -v "${ED}/usr/bin/foomatic-rip" || die
+ rm -v "${ED}/usr/libexec/cups/filter/foomatic-rip" || die
+ rm -v "${ED}/usr/share/man/man1/foomatic-rip.1" || die
+ fi
+
+ doinitd "${T}"/cups-browsed
+ systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+pkg_postinst() {
+ if ! use foomatic ; then
+ ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+ ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+ fi
+}