summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 18:32:56 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:34:16 +0100
commit3fd146ede028edfb103f117e53e6ef2dfc73a792 (patch)
treee73bf20a70354fbb58835df9e2ca166a2081819a /net-print
parentnet-nntp/sabnzbd: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-3fd146ede028edfb103f117e53e6ef2dfc73a792.tar.gz
gentoo-3fd146ede028edfb103f117e53e6ef2dfc73a792.tar.bz2
gentoo-3fd146ede028edfb103f117e53e6ef2dfc73a792.zip
net-print/hplip: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip/hplip-3.18.12-r1.ebuild (renamed from net-print/hplip/hplip-3.18.12.ebuild)36
-rw-r--r--net-print/hplip/hplip-3.19.11.ebuild36
-rw-r--r--net-print/hplip/hplip-3.19.12-r1.ebuild (renamed from net-print/hplip/hplip-3.19.12.ebuild)36
3 files changed, 57 insertions, 51 deletions
diff --git a/net-print/hplip/hplip-3.18.12.ebuild b/net-print/hplip/hplip-3.18.12-r1.ebuild
index b28c7ba4201f..6c7b5ccefb0f 100644
--- a/net-print/hplip/hplip-3.18.12.ebuild
+++ b/net-print/hplip/hplip-3.18.12-r1.ebuild
@@ -49,26 +49,28 @@ RDEPEND="
${COMMON_DEPEND}
app-text/ghostscript-gpl
!minimal? (
- >=dev-python/dbus-python-1.2.0-r1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pygobject:2[${PYTHON_USEDEP}]' 'python2*')
- $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]' 'python3*')
- fax? ( dev-python/reportlab[${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep 'dev-python/pygobject:2[${PYTHON_MULTI_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]' 'python3*')
kernel_linux? ( virtual/udev )
- qt5? (
- >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,${PYTHON_USEDEP}]
- libnotify? ( dev-python/notify2[${PYTHON_USEDEP}] )
- )
- scanner? (
- >=dev-python/reportlab-3.2[${PYTHON_USEDEP}]
- >=dev-python/pillow-3.1.1[${PYTHON_USEDEP}]
- X? (
- || (
- kde? ( kde-misc/skanlite )
- media-gfx/xsane
- media-gfx/sane-frontends
+ $(python_gen_cond_dep '
+ >=dev-python/dbus-python-1.2.0-r1[${PYTHON_MULTI_USEDEP}]
+ fax? ( dev-python/reportlab[${PYTHON_MULTI_USEDEP}] )
+ qt5? (
+ >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,${PYTHON_MULTI_USEDEP}]
+ libnotify? ( dev-python/notify2[${PYTHON_MULTI_USEDEP}] )
+ )
+ scanner? (
+ >=dev-python/reportlab-3.2[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pillow-3.1.1[${PYTHON_MULTI_USEDEP}]
+ X? (
+ || (
+ kde? ( kde-misc/skanlite )
+ media-gfx/xsane
+ media-gfx/sane-frontends
+ )
)
)
- )
+ ')
)
policykit? ( sys-auth/polkit )
"
diff --git a/net-print/hplip/hplip-3.19.11.ebuild b/net-print/hplip/hplip-3.19.11.ebuild
index 83e3e5a46112..0d2eb10db37c 100644
--- a/net-print/hplip/hplip-3.19.11.ebuild
+++ b/net-print/hplip/hplip-3.19.11.ebuild
@@ -49,26 +49,28 @@ RDEPEND="
${COMMON_DEPEND}
app-text/ghostscript-gpl
!minimal? (
- >=dev-python/dbus-python-1.2.0-r1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pygobject:2[${PYTHON_USEDEP}]' 'python2*')
- $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]' 'python3*')
- fax? ( dev-python/reportlab[${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep 'dev-python/pygobject:2[${PYTHON_MULTI_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]' 'python3*')
kernel_linux? ( virtual/udev )
- qt5? (
- >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,${PYTHON_USEDEP}]
- libnotify? ( dev-python/notify2[${PYTHON_USEDEP}] )
- )
- scanner? (
- >=dev-python/reportlab-3.2[${PYTHON_USEDEP}]
- >=dev-python/pillow-3.1.1[${PYTHON_USEDEP}]
- X? (
- || (
- kde? ( kde-misc/skanlite )
- media-gfx/xsane
- media-gfx/sane-frontends
+ $(python_gen_cond_dep '
+ >=dev-python/dbus-python-1.2.0-r1[${PYTHON_MULTI_USEDEP}]
+ fax? ( dev-python/reportlab[${PYTHON_MULTI_USEDEP}] )
+ qt5? (
+ >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,${PYTHON_MULTI_USEDEP}]
+ libnotify? ( dev-python/notify2[${PYTHON_MULTI_USEDEP}] )
+ )
+ scanner? (
+ >=dev-python/reportlab-3.2[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pillow-3.1.1[${PYTHON_MULTI_USEDEP}]
+ X? (
+ || (
+ kde? ( kde-misc/skanlite )
+ media-gfx/xsane
+ media-gfx/sane-frontends
+ )
)
)
- )
+ ')
)
policykit? ( sys-auth/polkit )
"
diff --git a/net-print/hplip/hplip-3.19.12.ebuild b/net-print/hplip/hplip-3.19.12-r1.ebuild
index 83e3e5a46112..0d2eb10db37c 100644
--- a/net-print/hplip/hplip-3.19.12.ebuild
+++ b/net-print/hplip/hplip-3.19.12-r1.ebuild
@@ -49,26 +49,28 @@ RDEPEND="
${COMMON_DEPEND}
app-text/ghostscript-gpl
!minimal? (
- >=dev-python/dbus-python-1.2.0-r1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pygobject:2[${PYTHON_USEDEP}]' 'python2*')
- $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]' 'python3*')
- fax? ( dev-python/reportlab[${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep 'dev-python/pygobject:2[${PYTHON_MULTI_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]' 'python3*')
kernel_linux? ( virtual/udev )
- qt5? (
- >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,${PYTHON_USEDEP}]
- libnotify? ( dev-python/notify2[${PYTHON_USEDEP}] )
- )
- scanner? (
- >=dev-python/reportlab-3.2[${PYTHON_USEDEP}]
- >=dev-python/pillow-3.1.1[${PYTHON_USEDEP}]
- X? (
- || (
- kde? ( kde-misc/skanlite )
- media-gfx/xsane
- media-gfx/sane-frontends
+ $(python_gen_cond_dep '
+ >=dev-python/dbus-python-1.2.0-r1[${PYTHON_MULTI_USEDEP}]
+ fax? ( dev-python/reportlab[${PYTHON_MULTI_USEDEP}] )
+ qt5? (
+ >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,${PYTHON_MULTI_USEDEP}]
+ libnotify? ( dev-python/notify2[${PYTHON_MULTI_USEDEP}] )
+ )
+ scanner? (
+ >=dev-python/reportlab-3.2[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pillow-3.1.1[${PYTHON_MULTI_USEDEP}]
+ X? (
+ || (
+ kde? ( kde-misc/skanlite )
+ media-gfx/xsane
+ media-gfx/sane-frontends
+ )
)
)
- )
+ ')
)
policykit? ( sys-auth/polkit )
"