summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-11-24 15:01:14 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2020-11-24 15:03:44 -0800
commit467014aadc7dd5e85c0aa4e25083d7a67b8c95c5 (patch)
treeb1e59d8b126c511a84cf9e509f24a64e024ac0aa /net-print
parentapp-office/libreoffice: fix app-text/libnumbertext dep (diff)
downloadgentoo-467014aadc7dd5e85c0aa4e25083d7a67b8c95c5.tar.gz
gentoo-467014aadc7dd5e85c0aa4e25083d7a67b8c95c5.tar.bz2
gentoo-467014aadc7dd5e85c0aa4e25083d7a67b8c95c5.zip
net-print/dymo-cups-drivers: compile-fix for cups-2.3
Fixes: https://bugs.gentoo.org/show_bug.cgi?id=693652 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/dymo-cups-drivers/dymo-cups-drivers-1.4.0-r2.ebuild55
-rw-r--r--net-print/dymo-cups-drivers/files/cups-2.3.0-headers.patch24
2 files changed, 79 insertions, 0 deletions
diff --git a/net-print/dymo-cups-drivers/dymo-cups-drivers-1.4.0-r2.ebuild b/net-print/dymo-cups-drivers/dymo-cups-drivers-1.4.0-r2.ebuild
new file mode 100644
index 000000000000..bd4c15c361e9
--- /dev/null
+++ b/net-print/dymo-cups-drivers/dymo-cups-drivers-1.4.0-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils autotools
+
+DESCRIPTION="Dymo SDK for LabelWriter/LabelManager printers"
+HOMEPAGE="https://newellrubbermaid.secure.force.com/dymopkb"
+SRC_URI="http://download.dymo.com/Download%20Drivers/Linux/Download/${P}.tar.gz"
+
+S="${WORKDIR}/${P}.5"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test usb_modeswitch"
+RESTRICT="!test? ( test )"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=net-print/cups-2.3.0"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )
+ usb_modeswitch? ( sys-apps/usb_modeswitch )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.0-cxxflags.patch
+ "${FILESDIR}"/port_to_newer_cups_headers.patch
+ "${FILESDIR}"/dymo-cups-drivers-1.4.0.5-flexible-tests.patch
+ "${FILESDIR}"/cups-2.3.0-headers.patch
+)
+
+DOCS=( AUTHORS README ChangeLog docs/SAMPLES )
+
+src_prepare() {
+ default
+ eapply_user
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc docs/*.{txt,rtf,ps,png}
+}
+
+src_test() {
+ # upstream tests are designed to be run AFTER make install, because they depend on final paths.
+ testroot="${T}/testroot"
+ mkdir -p "${testroot}"
+ emake install DESTDIR="${testroot}"
+ # -W filters is because CUPS tries really hard for secure filters: they must be root/root for the filter tests to pass
+ #chown root:root "${testroot}"/usr/libexec/cups/filter/{raster2dymolm,raster2dymolw} || die "failed to set ownership for tests"
+ # This will trigger the following warning repeatedly
+ #Bad permissions on cupsFilter file "..${testroot}/usr/libexec/cups/filter/raster2dymolm"
+ emake check CUPSTESTPPD_OPTS="-R ${testroot} -W filters"
+}
diff --git a/net-print/dymo-cups-drivers/files/cups-2.3.0-headers.patch b/net-print/dymo-cups-drivers/files/cups-2.3.0-headers.patch
new file mode 100644
index 000000000000..059c3d0c29c1
--- /dev/null
+++ b/net-print/dymo-cups-drivers/files/cups-2.3.0-headers.patch
@@ -0,0 +1,24 @@
+https://github.com/codeprofis/dymo-cups-drivers/commit/948abc3500f45578a386182c0d2a55bcfcbc2c66.patch
+
+From 948abc3500f45578a386182c0d2a55bcfcbc2c66 Mon Sep 17 00:00:00 2001
+From: Florian Knodt <adlerweb@adlerweb.info>
+Date: Fri, 28 Feb 2020 23:26:34 +0100
+Subject: [PATCH] Add missing backend header. Fixes #11.
+
+---
+ src/common/CupsPrintEnvironment.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/common/CupsPrintEnvironment.h b/src/common/CupsPrintEnvironment.h
+index 23043d8..76ecefc 100644
+--- a/src/common/CupsPrintEnvironment.h
++++ b/src/common/CupsPrintEnvironment.h
+@@ -21,6 +21,8 @@
+ #ifndef h952b1c81_8931_433a_8479_7ae6d8e85a86
+ #define h952b1c81_8931_433a_8479_7ae6d8e85a86
+
++#include <cups/backend.h>
++#include <cups/sidechannel.h>
+ #include "PrinterDriver.h"
+
+ namespace DymoPrinterDriver