summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-03-07 20:31:25 +0000
committerJames Le Cuirot <chewi@gentoo.org>2020-03-07 20:31:25 +0000
commit4e30ca421c4ca0815b2d1de2edceb1c988831973 (patch)
tree2f08dcaab0384ad546adce6a9d8a0040b31a534f /net-print
parentmedia-video/makemkv: Bump to 1.15.0, drop old 1.14.7 (diff)
downloadgentoo-4e30ca421c4ca0815b2d1de2edceb1c988831973.tar.gz
gentoo-4e30ca421c4ca0815b2d1de2edceb1c988831973.tar.bz2
gentoo-4e30ca421c4ca0815b2d1de2edceb1c988831973.zip
net-print/hplip-plugin: Version bump to 3.19.12
Closes: https://bugs.gentoo.org/709546 Package-Manager: Portage-2.3.92, Repoman-2.3.20 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.19.12.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 107899dd02df..985dc1ae6905 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,2 +1,3 @@
DIST hplip-3.18.12-plugin.run 10486821 BLAKE2B e48940b1b5fe94dc216383b63bee7807bce9ad265b7c454c201c0ed22ec1964e6c5adf653c3c230789c042cffaaf50bd604bae6f66f407a85f98248934307158 SHA512 82b90aa8245f787e088a1bebfa7892a7f2b97fd04b3702c46eed27306640e562aeec63b4b5b45c24943abe4672f2627d1821bdcdf58a5c1ac4e1d06c7270535f
DIST hplip-3.19.11-plugin.run 11517119 BLAKE2B d7eefde4e579abbb019cfbb5bf7541360884b0d18240c87c0b532981ad3542a60dae139a623db0eaee3057d6fb5e805287ad5bddb2ec87df5b85ffd604f748f4 SHA512 9ef568aa297eb58370e7f01e54d83c53fbfb02494a0f4cfa3b9f92fd11bfae7b9f54d60516d5cf0436a882864505aab68f70b462b820e918a6ad4104987c9295
+DIST hplip-3.19.12-plugin.run 11512079 BLAKE2B 534cbba51b2254f8227611b8f0449e100361fb445400f664e43e30412be8eb554bb35c2fe260d45cd5ad742b083af6d551532a9d14585029b0ff93675fab578a SHA512 ac2022d555f5084d5bf1e4519ddbb29828e9ca385aa6dff818ae9e79b60b4b2745e31ad4146cb01bca3747fae0d61b96e4a823b81179d2e2c55a643831165e4b
diff --git a/net-print/hplip-plugin/hplip-plugin-3.19.12.ebuild b/net-print/hplip-plugin/hplip-plugin-3.19.12.ebuild
new file mode 100644
index 000000000000..315136510139
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.19.12.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/libusb:0
+ virtual/udev
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PRESTRIPPED="
+ /usr/share/hplip/fax/plugins/fax_marvell.so
+ /usr/share/hplip/prnt/plugins/hbpl1.so
+ /usr/share/hplip/prnt/plugins/lj.so
+ /usr/share/hplip/scan/plugins/bb_escl.so
+ /usr/share/hplip/scan/plugins/bb_marvell.so
+ /usr/share/hplip/scan/plugins/bb_soapht.so
+ /usr/share/hplip/scan/plugins/bb_soap.so
+"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_install() {
+ local hplip_arch
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ arm) hplip_arch="arm32" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ fax_*) plugin_type=fax ;;
+ bb_*) plugin_type=scan ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}