summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-12-04 16:53:39 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2016-12-05 07:56:22 -0800
commite9676800911f550b2dd174a5916bc4e555ad0159 (patch)
tree56947f0e1e4b63c0025df94fa7a6f282fde5a44d /net-proxy/haproxy/files
parentnet-proxy/haproxy: prepare for split 9999 on different major versions (diff)
downloadgentoo-e9676800911f550b2dd174a5916bc4e555ad0159.tar.gz
gentoo-e9676800911f550b2dd174a5916bc4e555ad0159.tar.bz2
gentoo-e9676800911f550b2dd174a5916bc4e555ad0159.zip
net-proxy/haproxy: 9999-style builds for current major versions.
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-proxy/haproxy/files')
-rw-r--r--net-proxy/haproxy/files/haproxy-1.7-contrib.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-proxy/haproxy/files/haproxy-1.7-contrib.patch b/net-proxy/haproxy/files/haproxy-1.7-contrib.patch
new file mode 100644
index 000000000000..836c4cf71de1
--- /dev/null
+++ b/net-proxy/haproxy/files/haproxy-1.7-contrib.patch
@@ -0,0 +1,42 @@
+diff -Nuar --exclude '*~' haproxy-1.7.9999.orig/contrib/tcploop/Makefile haproxy-1.7.9999/contrib/tcploop/Makefile
+--- haproxy-1.7.9999.orig/contrib/tcploop/Makefile 2016-12-04 16:08:05.497256646 -0800
++++ haproxy-1.7.9999/contrib/tcploop/Makefile 2016-12-04 16:12:20.558141392 -0800
+@@ -5,7 +5,7 @@
+ OBJS = tcploop
+
+ tcploop: tcploop.c
+- $(CC) $(OPTIMIZE) $(DEFINE) $(INCLUDE) -o $@ $^
++ $(CC) $(OPTIMIZE) $(DEFINE) $(INCLUDE) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ clean:
+ rm -f $(OBJS) *.[oas] *~
+diff -Nuar --exclude '*~' haproxy-1.7.9999.orig/contrib/tcploop/tcploop.c haproxy-1.7.9999/contrib/tcploop/tcploop.c
+--- haproxy-1.7.9999.orig/contrib/tcploop/tcploop.c 2016-12-04 16:08:05.498256665 -0800
++++ haproxy-1.7.9999/contrib/tcploop/tcploop.c 2016-12-04 16:11:13.877864378 -0800
+@@ -39,6 +39,7 @@
+ #include <ctype.h>
+ #include <errno.h>
+ #include <fcntl.h>
++#include <limits.h>
+ #include <netdb.h>
+ #include <poll.h>
+ #include <signal.h>
+diff -Nuar --exclude '*~' haproxy-1.7.9999.orig/contrib/spoa_example/Makefile haproxy-1.7.9999/contrib/spoa_example/Makefile
+--- haproxy-1.7.9999.orig/contrib/spoa_example/Makefile 2016-12-04 15:56:49.068302156 -0800
++++ haproxy-1.7.9999/contrib/spoa_example/Makefile 2016-12-04 15:58:51.360644213 -0800
+@@ -6,13 +6,13 @@
+ LD = $(CC)
+
+ CFLAGS = -g -O2 -Wall -Werror -pthread
+-LDFLAGS = -lpthread
++LIBS = -lpthread
+
+ OBJS = spoa.o
+
+
+ spoa: $(OBJS)
+- $(LD) $(LDFLAGS) -o $@ $^
++ $(LD) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ install: spoa
+ install spoa $(DESTDIR)$(BINDIR)