summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-12-04 16:53:39 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2016-12-05 07:56:22 -0800
commite9676800911f550b2dd174a5916bc4e555ad0159 (patch)
tree56947f0e1e4b63c0025df94fa7a6f282fde5a44d /net-proxy/haproxy/haproxy-1.6.9999.ebuild
parentnet-proxy/haproxy: prepare for split 9999 on different major versions (diff)
downloadgentoo-e9676800911f550b2dd174a5916bc4e555ad0159.tar.gz
gentoo-e9676800911f550b2dd174a5916bc4e555ad0159.tar.bz2
gentoo-e9676800911f550b2dd174a5916bc4e555ad0159.zip
net-proxy/haproxy: 9999-style builds for current major versions.
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-proxy/haproxy/haproxy-1.6.9999.ebuild')
-rw-r--r--net-proxy/haproxy/haproxy-1.6.9999.ebuild57
1 files changed, 38 insertions, 19 deletions
diff --git a/net-proxy/haproxy/haproxy-1.6.9999.ebuild b/net-proxy/haproxy/haproxy-1.6.9999.ebuild
index 97a58d9c88f9..df81d1e500a9 100644
--- a/net-proxy/haproxy/haproxy-1.6.9999.ebuild
+++ b/net-proxy/haproxy/haproxy-1.6.9999.ebuild
@@ -4,18 +4,24 @@
EAPI="6"
-inherit user versionator toolchain-funcs flag-o-matic systemd linux-info git-r3
+[[ ${PV} == *9999 ]] && SCM="git-r3"
+inherit user versionator toolchain-funcs flag-o-matic systemd linux-info $SCM
MY_P="${PN}-${PV/_beta/-dev}"
DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
HOMEPAGE="http://haproxy.1wt.eu"
-EGIT_REPO_URI="http://master.formilux.org/git/people/willy/haproxy.git"
+if [[ ${PV} != *9999 ]]; then
+ SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+else
+ EGIT_REPO_URI="http://git.haproxy.org/git/haproxy-$(get_version_component_range 1-2).git/"
+ EGIT_BRANCH=master
+fi
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS=""
-IUSE="+crypt doc examples libressl slz net_ns +pcre pcre-jit ssl tools vim-syntax +zlib" # lua
+IUSE="+crypt doc examples libressl slz net_ns +pcre pcre-jit ssl tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
REQUIRED_USE="pcre-jit? ( pcre )
?? ( slz zlib )"
@@ -29,13 +35,18 @@ DEPEND="
libressl? ( dev-libs/libressl:0= )
)
slz? ( dev-libs/libslz:= )
- zlib? ( sys-libs/zlib )"
-# lua? ( dev-lang/lua:5.3 )
+ zlib? ( sys-libs/zlib )
+ lua? ( dev-lang/lua:5.3 )
+ device-atlas? ( dev-libs/device-atlas-api-c )"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
-DOCS=( CHANGELOG CONTRIBUTING MAINTAINERS )
+DOCS=( CHANGELOG CONTRIBUTING MAINTAINERS README )
+version_is_at_least 1.7.0 $PV && PATCHES=( "${FILESDIR}"/haproxy-1.7-contrib.patch )
+CONTRIBS=( halog iprange )
+# ip6range is present in 1.6, but broken.
+version_is_at_least 1.7.0 $PV && CONTRIBS+=( ip6range spoa_example tcploop )
haproxy_use() {
(( $# != 2 )) && die "${FUNCNAME} <USE flag> <make option>"
@@ -66,19 +77,20 @@ src_compile() {
local -a args=(
TARGET=linux2628
USE_GETADDRINFO=1
+ USE_TFO=1
)
args+=( $(haproxy_use crypt LIBCRYPT) )
-
-# bug 541042
-# args+=( $(haproxy_use lua LUA) )
-
args+=( $(haproxy_use net_ns NS) )
args+=( $(haproxy_use pcre PCRE) )
args+=( $(haproxy_use pcre-jit PCRE_JIT) )
args+=( $(haproxy_use ssl OPENSSL) )
args+=( $(haproxy_use slz SLZ) )
args+=( $(haproxy_use zlib ZLIB) )
+ args+=( $(haproxy_use lua LUA) )
+ args+=( $(haproxy_use 51degrees 51DEGREES) )
+ args+=( $(haproxy_use device-atlas DEVICEATLAS) )
+ args+=( $(haproxy_use wurfl WURFL) )
# For now, until the strict-aliasing breakage will be fixed
append-cflags -fno-strict-aliasing
@@ -86,7 +98,7 @@ src_compile() {
emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args[@]}
if use tools ; then
- for contrib in halog iprange ; do
+ for contrib in ${CONTRIBS[@]} ; do
emake -C contrib/${contrib} \
CFLAGS="${CFLAGS}" OPTIMIZE="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args[@]}
done
@@ -106,17 +118,24 @@ src_install() {
einstalldocs
+ # The errorfiles are used by upstream defaults.
+ insinto /etc/haproxy/errors/
+ doins examples/errorfiles/*
+
if use doc; then
- dodoc ROADMAP doc/{close-options,configuration,cookie-options,intro,linux-syn-cookies,management,proxy-protocol}.txt
+ dodoc ROADMAP doc/*.txt
+ #if use lua; then
+ # TODO: doc/lua-api/
+ #fi
fi
if use tools ; then
- dobin contrib/halog/halog
- newbin contrib/iprange/iprange haproxy_iprange
- fi
-
- if use net_ns && use doc; then
- dodoc doc/network-namespaces.txt
+ has halog "${CONTRIBS[@]}" && dobin contrib/halog/halog
+ has "iprange" "${CONTRIBS[@]}" && newbin contrib/iprange/iprange haproxy_iprange
+ has "ip6range" "${CONTRIBS[@]}" && newbin contrib/ip6range/ip6range haproxy_ip6range
+ has "spoa_example" "${CONTRIBS[@]}" && newbin contrib/spoa_example/spoa haproxy_spoa_example
+ has "spoa_example" "${CONTRIBS[@]}" && newdoc contrib/spoa_example/README README.spoa_example
+ has "tcploop" "${CONTRIBS[@]}" && newbin contrib/tcploop/tcploop haproxy_tcploop
fi
if use examples ; then