summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2016-01-06 12:45:39 +0100
committerChristian Ruppert <idl0r@gentoo.org>2016-01-06 12:45:55 +0100
commitfde90adcc8162d7266de3d32d5b2891d8e69fa47 (patch)
treeb99987495282988b8270faf1e70a2c5bef8ada9c /net-proxy/haproxy
parentnet-proxy/haproxy: Remove 1.6.1 (diff)
downloadgentoo-fde90adcc8162d7266de3d32d5b2891d8e69fa47.tar.gz
gentoo-fde90adcc8162d7266de3d32d5b2891d8e69fa47.tar.bz2
gentoo-fde90adcc8162d7266de3d32d5b2891d8e69fa47.zip
net-proxy/haproxy: Version bump to 1.6.3
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-proxy/haproxy')
-rw-r--r--net-proxy/haproxy/Manifest1
-rw-r--r--net-proxy/haproxy/haproxy-1.6.3.ebuild161
2 files changed, 162 insertions, 0 deletions
diff --git a/net-proxy/haproxy/Manifest b/net-proxy/haproxy/Manifest
index d8171cbe52bf..73381094137f 100644
--- a/net-proxy/haproxy/Manifest
+++ b/net-proxy/haproxy/Manifest
@@ -2,3 +2,4 @@ DIST haproxy-1.4.26.tar.gz 837280 SHA256 a8787dae723c045eebd0ed9e0213514f909a673
DIST haproxy-1.5.14.tar.gz 1345345 SHA256 9565dd38649064d0350a2883fa81ccfe92eb17dcda457ebdc01535e1ab0c8f99 SHA512 83d6101fd402f37845ab3febc914335e4c6d9bdebbb0ff81c8e048d5252ffa5a1b77c4250a434fed5dd541ef1f1f2c47d969b59f7a51d6ab9aea38a8646a9798 WHIRLPOOL 7d2c580589b9b31e1eba169e4bf930ac42d2564e21eb1c25adbdd39b701abd221fd671ebc227167ab956a48b2c30eeb740a6394355a8fa748c408ee42fdff6fc
DIST haproxy-1.5.15.tar.gz 1356790 SHA256 5af46e1438601d0919f5628081f660f9533087d88af3d9274f245395475663e1 SHA512 9c4f1b5ebd2401e5a13f5929b3d8fc7f93fde694971a8f0cead8ad3d166779b1dd0e3da9c872f4681d7fc55d87ff4cb4396024eea34e1482d400707d275d4715 WHIRLPOOL d37d4f9d8dccd24d2955eda9ff16a114d5d005f3589713c9607aec2f83dc24fc7f8f0c47b1067547e3fb84acaae6f68a7432c7fb3120ccb16c874bceb0e80792
DIST haproxy-1.6.2.tar.gz 1538976 SHA256 bd4a7eee79e1bfd25af59d956bb60e82acbb6f146f3fb3b30636036f4c9548d3 SHA512 8cb1f2bb7e63e75b1350e37b4a06dae9627bc6004ceefc0e3dac7c6f56ea66cdc41ebaee0e536a5acbd4e5b067feba2589d3e360dd7fdc6d3d67c000f6c83ba9 WHIRLPOOL 9c4461c74959e896c0135bcd87830667ff8aa8fe23019ca0e4bc97a981acda75026f067bf860cde984adfa76db8ac8dea351cd2ec45c28d61587ea1dea9fe914
+DIST haproxy-1.6.3.tar.gz 1555861 SHA256 fd06b45054cde2c69cb3322dfdd8a4bcfc46eb9d0c4b36d20d3ea19d84e338a7 SHA512 79ed526cd857dcd68d9b8289df4d4a2d87594e8d0d119f4d7c618597db7563a0cedc8417ddcfefb464a322d1fb50cb044656a2fbe78867f58052e0ddaa894bb9 WHIRLPOOL 37c6e1b0b063d8956d69039b55583320f4e191c1f9212b86ff1e8aef7b51f7e1228ad5923b86db893e25fb0ebb9d0570e88930cf45bc88a4a328e9576d982d30
diff --git a/net-proxy/haproxy/haproxy-1.6.3.ebuild b/net-proxy/haproxy/haproxy-1.6.3.ebuild
new file mode 100644
index 000000000000..3f896e807afd
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.6.3.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit user versionator toolchain-funcs flag-o-matic systemd linux-info
+
+MY_P="${PN}-${PV/_beta/-dev}"
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+crypt doc examples net_ns +pcre pcre-jit ssl tools vim-syntax +zlib" # lua
+
+DEPEND="pcre? ( dev-libs/libpcre
+ pcre-jit? ( dev-libs/libpcre[jit] )
+ )
+ ssl? ( dev-libs/openssl:0[zlib?] )
+ zlib? ( sys-libs/zlib )"
+# lua? ( dev-lang/lua:5.3 )
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup haproxy
+ enewuser haproxy -1 -1 -1 haproxy
+
+ if use net_ns; then
+ CONFIG_CHECK="~NET_NS"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -e 's:@SBINDIR@:'/usr/bin':' contrib/systemd/haproxy.service.in \
+ > contrib/systemd/haproxy.service || die
+
+ sed -ie 's:/usr/sbin/haproxy:/usr/bin/haproxy:' src/haproxy-systemd-wrapper.c || die
+}
+
+src_compile() {
+ local args="TARGET=linux2628 USE_GETADDRINFO=1"
+
+ if use crypt ; then
+ args="${args} USE_LIBCRYPT=1"
+ else
+ args="${args} USE_LIBCRYPT="
+ fi
+
+# bug 541042
+# if use lua; then
+# args="${args} USE_LUA=1"
+# else
+ args="${args} USE_LUA="
+# fi
+
+ if use net_ns; then
+ args="${args} USE_NS=1"
+ else
+ args="${args} USE_NS="
+ fi
+
+ if use pcre ; then
+ args="${args} USE_PCRE=1"
+ if use pcre-jit; then
+ args="${args} USE_PCRE_JIT=1"
+ else
+ args="${args} USE_PCRE_JIT="
+ fi
+ else
+ args="${args} USE_PCRE= USE_PCRE_JIT="
+ fi
+
+# if use kernel_linux; then
+# args="${args} USE_LINUX_SPLICE=1 USE_LINUX_TPROXY=1"
+# else
+# args="${args} USE_LINUX_SPLICE= USE_LINUX_TPROXY="
+# fi
+
+ if use ssl ; then
+ args="${args} USE_OPENSSL=1"
+ else
+ args="${args} USE_OPENSSL="
+ fi
+
+ if use zlib ; then
+ args="${args} USE_ZLIB=1"
+ else
+ args="${args} USE_ZLIB="
+ fi
+
+ # For now, until the strict-aliasing breakage will be fixed
+ append-cflags -fno-strict-aliasing
+
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args}
+
+ if use tools ; then
+ for contrib in halog iprange ; do
+ emake -C contrib/${contrib} \
+ CFLAGS="${CFLAGS}" OPTIMIZE="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args}
+ done
+ fi
+}
+
+src_install() {
+ dobin haproxy
+
+ newconfd "${FILESDIR}/${PN}.confd" $PN
+ newinitd "${FILESDIR}/${PN}.initd-r3" $PN
+
+ dodoc CHANGELOG CONTRIBUTING MAINTAINERS
+ doman doc/haproxy.1
+
+ dobin haproxy-systemd-wrapper
+ systemd_dounit contrib/systemd/haproxy.service
+
+ if use doc; then
+ dodoc ROADMAP doc/{close-options,configuration,cookie-options,intro,linux-syn-cookies,management,proxy-protocol}.txt
+ fi
+
+ if use tools ; then
+ for contrib in halog iprange ; do
+ dobin contrib/${contrib}/${contrib}
+ done
+ fi
+
+ if use net_ns && use doc; then
+ dodoc doc/network-namespaces.txt
+ fi
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.cfg
+ dodoc examples/seamless_reload.txt
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/haproxy.vim
+ fi
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy/haproxy.cfg" ]] ; then
+ ewarn "You need to create /etc/haproxy/haproxy.cfg before you start the haproxy service."
+ ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
+ ewarn "Make use of them with the \"user\" and \"group\" directives."
+
+ if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${PF}"
+ fi
+ fi
+}