summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-proxy/ntlmaps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-proxy/ntlmaps')
-rw-r--r--net-proxy/ntlmaps/Manifest2
-rw-r--r--net-proxy/ntlmaps/files/ntlmaps-0.9.9-gentoo.patch37
-rw-r--r--net-proxy/ntlmaps/files/ntlmaps-0.9.9.6-gentoo.patch33
-rw-r--r--net-proxy/ntlmaps/files/ntlmaps.init27
-rw-r--r--net-proxy/ntlmaps/files/ntlmaps.service10
-rw-r--r--net-proxy/ntlmaps/metadata.xml15
-rw-r--r--net-proxy/ntlmaps/ntlmaps-0.9.9-r2.ebuild61
-rw-r--r--net-proxy/ntlmaps/ntlmaps-0.9.9.6-r3.ebuild56
8 files changed, 241 insertions, 0 deletions
diff --git a/net-proxy/ntlmaps/Manifest b/net-proxy/ntlmaps/Manifest
new file mode 100644
index 000000000000..0582477aab11
--- /dev/null
+++ b/net-proxy/ntlmaps/Manifest
@@ -0,0 +1,2 @@
+DIST ntlmaps-0.9.9.6.tar.gz 60760 SHA256 005c66a84f535951dc6ad558b301b7b49b96a3bbc56e3a83a553a5500e3f6a2a SHA512 0b0c80f3a32c523fdad47af2d0c7fa21d01124d014aafb2f7e9a00ba525685917b6c24572a25d5c294848f88fd6775a0e9c9e95014d91e35b86411c83f12adff WHIRLPOOL 66431212f20e5451992a2f788d7c8077dae95ee3cb97e956bd65862ce9c93fe2bea31e46cf34922fe5cbd99c6ea5780cfecd3fbadc128cbbd820c5c772f9371e
+DIST ntlmaps-0.9.9.tar.gz 55459 SHA256 6f955ef0a8f3e944df0a9b2d22e385ee4399fa4e16f4c30ccdcb6f4c92fdccd1
diff --git a/net-proxy/ntlmaps/files/ntlmaps-0.9.9-gentoo.patch b/net-proxy/ntlmaps/files/ntlmaps-0.9.9-gentoo.patch
new file mode 100644
index 000000000000..02e90f2ccf9d
--- /dev/null
+++ b/net-proxy/ntlmaps/files/ntlmaps-0.9.9-gentoo.patch
@@ -0,0 +1,37 @@
+diff -Nru ntlmaps-0.9.9.orig/__init__.py ntlmaps-0.9.9/__init__.py
+--- ntlmaps-0.9.9.orig/__init__.py 2004-11-10 01:27:05.000000000 +0200
++++ ntlmaps-0.9.9/__init__.py 2005-02-24 13:07:56.601327735 +0200
+@@ -22,8 +22,7 @@
+
+ import os, sys
+
+-ntlmaps_dir = os.path.dirname(os.path.abspath(__file__))
+-ntlmaps_libdir = ntlmaps_dir + '/lib'
++ntlmaps_dir = '/usr/lib/ntlmaps'
+ sys.path.append(ntlmaps_libdir)
+
+ del os, sys
+diff -Nru ntlmaps-0.9.9.orig/main.py ntlmaps-0.9.9/main.py
+--- ntlmaps-0.9.9.orig/main.py 2005-02-01 04:45:02.000000000 +0200
++++ ntlmaps-0.9.9/main.py 2005-02-24 13:11:46.762545214 +0200
+@@ -18,17 +18,17 @@
+ # Free Software Foundation, Inc.,
+ # 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA.
+ #
+-import __init__
+-
+ import sys
+
++sys.path.append('/usr/lib/ntlmaps')
++
+ import server, config, config_affairs
+
+
+ #--------------------------------------------------------------
+ # config affairs
+ # look for default config name in lib/config.py
+-conf = config.read_config(config.findConfigFileNameInArgv(sys.argv, __init__.ntlmaps_dir+'/'))
++conf = config.read_config('/etc/ntlmaps/server.cfg')
+
+ conf['GENERAL']['VERSION'] = '0.9.9'
+
diff --git a/net-proxy/ntlmaps/files/ntlmaps-0.9.9.6-gentoo.patch b/net-proxy/ntlmaps/files/ntlmaps-0.9.9.6-gentoo.patch
new file mode 100644
index 000000000000..bda0843e6c9f
--- /dev/null
+++ b/net-proxy/ntlmaps/files/ntlmaps-0.9.9.6-gentoo.patch
@@ -0,0 +1,33 @@
+--- __init__.py.old 2010-10-06 16:03:54.000000000 +0200
++++ __init__.py 2010-10-06 16:05:38.000000000 +0200
+@@ -20,10 +20,3 @@
+ # 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA.
+ #
+
+-import os, sys
+-
+-ntlmaps_dir = os.path.dirname(os.path.abspath(__file__))
+-ntlmaps_libdir = ntlmaps_dir + '/lib'
+-sys.path.append(ntlmaps_libdir)
+-
+-del os, sys
+--- main.py.old 2010-10-06 16:26:57.000000000 +0200
++++ main.py 2010-10-06 16:27:29.000000000 +0200
+@@ -18,8 +18,6 @@
+ # Free Software Foundation, Inc.,
+ # 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA.
+ #
+-import __init__
+-
+ import sys
+
+ import server, config, config_affairs
+@@ -28,7 +26,7 @@
+ #--------------------------------------------------------------
+ # config affairs
+ # look for default config name in lib/config.py
+-conf = config.read_config(config.findConfigFileNameInArgv(sys.argv, __init__.ntlmaps_dir+'/'))
++conf = config.read_config('/etc/ntlmaps/server.cfg')
+
+ conf['GENERAL']['VERSION'] = '0.9.9.6'
+
diff --git a/net-proxy/ntlmaps/files/ntlmaps.init b/net-proxy/ntlmaps/files/ntlmaps.init
new file mode 100644
index 000000000000..0d0251660670
--- /dev/null
+++ b/net-proxy/ntlmaps/files/ntlmaps.init
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+PID_FILE="/var/run/ntlmaps.pid"
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ntlmaps"
+ touch ${PID_FILE}
+ chown ntlmaps:ntlmaps ${PID_FILE}
+ cd /var/log/ntlmaps && \
+ start-stop-daemon --quiet --start --background --exec /usr/bin/python \
+ --make-pidfile --pidfile ${PID_FILE} --chuid ntlmaps -- /usr/bin/ntlmaps < /dev/null && \
+ sleep 1
+ eend $?
+}
+stop() {
+ ebegin "Stopping ntlmaps"
+ start-stop-daemon --stop --quiet --pidfile ${PID_FILE} && \
+ rm -f ${PID_FILE}
+ eend $?
+}
diff --git a/net-proxy/ntlmaps/files/ntlmaps.service b/net-proxy/ntlmaps/files/ntlmaps.service
new file mode 100644
index 000000000000..163ab2623ed2
--- /dev/null
+++ b/net-proxy/ntlmaps/files/ntlmaps.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=NTLM proxy Authentication against MS proxy/web server
+Wants=network.target
+Before=network.target
+
+[Service]
+ExecStart=/usr/bin/ntlmaps
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-proxy/ntlmaps/metadata.xml b/net-proxy/ntlmaps/metadata.xml
new file mode 100644
index 000000000000..c40105f6d14d
--- /dev/null
+++ b/net-proxy/ntlmaps/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ ntlmaps is a http/ftp/socks proxy server written in python that
+ implements samba-like ntlm authentication against a Microsoft Proxy
+ Server (which does not support 'normal' digest authentication).
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ntlmaps</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-proxy/ntlmaps/ntlmaps-0.9.9-r2.ebuild b/net-proxy/ntlmaps/ntlmaps-0.9.9-r2.ebuild
new file mode 100644
index 000000000000..c23b818c53c4
--- /dev/null
+++ b/net-proxy/ntlmaps/ntlmaps-0.9.9-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils user
+
+DESCRIPTION="NTLM proxy Authentication against MS proxy/web server"
+HOMEPAGE="http://ntlmaps.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 x86"
+IUSE=""
+
+DEPEND="dev-lang/python"
+
+pkg_setup() {
+ enewgroup ntlmaps
+ enewuser ntlmaps -1 -1 -1 ntlmaps
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ sed -i -e 's/\r//' lib/*.py server.cfg *.txt doc/*.{txt,htm} || die 'Failed to convert line endings.'
+}
+
+src_install() {
+ exeinto /usr/bin
+ newexe main.py ntlmaps
+ insinto /usr/lib/ntlmaps
+ doins lib/*
+
+ dodoc *.txt doc/*.txt
+ dohtml doc/*
+
+ insopts -m0640 -g ntlmaps
+ insinto /etc/ntlmaps
+ doins server.cfg
+ newinitd "${FILESDIR}/ntlmaps.init" ntlmaps
+
+ diropts -m 0770 -g ntlmaps
+ keepdir /var/log/ntlmaps
+}
+
+pkg_preinst() {
+ #Remove the following lines sometime in December 2005
+ #Their purpose is to fix security bug #107766
+ if [ -f "${ROOT}/etc/ntlmaps/server.cfg" ]; then
+ chmod 0640 "${ROOT}/etc/ntlmaps/server.cfg"
+ chgrp ntlmaps "${ROOT}/etc/ntlmaps/server.cfg"
+ fi
+}
+
+pkg_prerm() {
+ einfo "Removing python compiled bytecode"
+ rm -f "${ROOT}"/usr/lib/ntlmaps/*.py?
+}
diff --git a/net-proxy/ntlmaps/ntlmaps-0.9.9.6-r3.ebuild b/net-proxy/ntlmaps/ntlmaps-0.9.9.6-r3.ebuild
new file mode 100644
index 000000000000..0773811d7052
--- /dev/null
+++ b/net-proxy/ntlmaps/ntlmaps-0.9.9.6-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils multilib systemd user python-r1
+
+DESCRIPTION="NTLM proxy Authentication against MS proxy/web server"
+HOMEPAGE="http://ntlmaps.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup ntlmaps
+ enewuser ntlmaps -1 -1 -1 ntlmaps
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ sed \
+ -e 's/\r//' \
+ -i lib/*.py server.cfg doc/*.{txt,htm} || die 'Failed to convert line endings.'
+}
+
+src_install() {
+ # Bug #351305, prevent file collision.
+ rm "${S}"/lib/utils.py || die
+
+ python_foreach_impl python_domodule lib/*.py
+
+ python_foreach_impl python_newscript main.py ntlmaps
+
+ python_foreach_impl python_optimize
+
+ dodoc doc/*.txt
+ dohtml doc/*.{gif,htm}
+
+ insopts -m0640 -g ntlmaps
+ insinto /etc/ntlmaps
+ doins server.cfg
+ newinitd "${FILESDIR}/ntlmaps.init" ntlmaps
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ diropts -m 0770 -g ntlmaps
+ keepdir /var/log/ntlmaps
+}