summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 14:06:24 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 14:17:01 -0500
commit2066a05b43df578a6fd35b4dc94e431782a2bcc3 (patch)
treeff822c333ace550e15629788741cb3a253b21a80 /net-proxy/nylon
parentnet-proxy/http-replicator: remove old versions (diff)
downloadgentoo-2066a05b43df578a6fd35b4dc94e431782a2bcc3.tar.gz
gentoo-2066a05b43df578a6fd35b4dc94e431782a2bcc3.tar.bz2
gentoo-2066a05b43df578a6fd35b4dc94e431782a2bcc3.zip
net-proxy/nylon: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-proxy/nylon')
-rw-r--r--net-proxy/nylon/files/nylon.init4
-rw-r--r--net-proxy/nylon/nylon-1.21-r2.ebuild36
2 files changed, 38 insertions, 2 deletions
diff --git a/net-proxy/nylon/files/nylon.init b/net-proxy/nylon/files/nylon.init
index 20a96da58b93..eb4ba694cb36 100644
--- a/net-proxy/nylon/files/nylon.init
+++ b/net-proxy/nylon/files/nylon.init
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-proxy/nylon/nylon-1.21-r2.ebuild b/net-proxy/nylon/nylon-1.21-r2.ebuild
new file mode 100644
index 000000000000..1f992210442f
--- /dev/null
+++ b/net-proxy/nylon/nylon-1.21-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="A lightweight SOCKS proxy server"
+HOMEPAGE="http://monkey.org/~marius/nylon/"
+SRC_URI="http://monkey.org/~marius/nylon/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libevent-0.6"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( README THANKS )
+
+src_prepare() {
+ default
+
+ eapply "${FILESDIR}"/${P}-libevent.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+ insinto /etc ; doins "${FILESDIR}/nylon.conf"
+ newinitd "${FILESDIR}/nylon.init" nylond
+}