summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-30 04:11:05 +0100
committerSam James <sam@gentoo.org>2022-09-30 04:11:18 +0100
commitb0b1b66a70addea502d60a9b6d6a86c075cb16f2 (patch)
tree846e8e7b54f031911049b91d9b89dfc0dbab4e60 /net-proxy/squid
parentsys-libs/uid_wrapper: drop 1.2.8 (diff)
downloadgentoo-b0b1b66a70addea502d60a9b6d6a86c075cb16f2.tar.gz
gentoo-b0b1b66a70addea502d60a9b6d6a86c075cb16f2.tar.bz2
gentoo-b0b1b66a70addea502d60a9b6d6a86c075cb16f2.zip
net-proxy/squid: fix disabling NTLM
While at it, tidy up some whitespace. Closes: https://bugs.gentoo.org/873427 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-proxy/squid')
-rw-r--r--net-proxy/squid/squid-5.7.ebuild27
1 files changed, 16 insertions, 11 deletions
diff --git a/net-proxy/squid/squid-5.7.ebuild b/net-proxy/squid/squid-5.7.ebuild
index f3ad18c4f62d..693209d20296 100644
--- a/net-proxy/squid/squid-5.7.ebuild
+++ b/net-proxy/squid/squid-5.7.ebuild
@@ -205,6 +205,8 @@ src_configure() {
myeconfargs+=( --without-mit-krb5 --without-heimdal-krb5 )
if use kerberos; then
+ # We intentionally overwrite negotiate_modules here to lose
+ # the 'none'.
negotiate_modules=( kerberos wrapper )
if has_version app-crypt/heimdal; then
@@ -221,10 +223,13 @@ src_configure() {
fi
# NTLM modules
- local ntlm_modules=(
- none
- $(usev samba 'SMB_LM')
- )
+ local ntlm_modules=( none )
+
+ if use samba ; then
+ # We intentionally overwrite modules here to lose
+ # the 'none'.
+ ntlm_modules=( $(usev samba 'SMB_LM') )
+ fi
# External helpers
local ext_helpers=(
@@ -240,7 +245,7 @@ src_configure() {
use ldap && use kerberos && ext_helpers+=( kerberos_ldap_group )
if use mysql || use postgres || use sqlite; then
- ext_helpers+=( SQL_session )
+ ext_helpers+=( SQL_session )
fi
# Storage modules
@@ -282,12 +287,12 @@ src_configure() {
}
myeconfargs+=(
- --enable-storeio=$(print_options_without_comma "${storeio_modules[@]}" )
- --enable-auth-basic=$(print_options_without_comma "${basic_modules[@]}" )
- --enable-auth-digest=$(print_options_without_comma "${digest_modules[@]}" )
- --enable-auth-ntlm=$(print_options_without_comma "${ntlm_modules[@]}" )
- --enable-auth-negotiate=$(print_options_without_comma "${negotiate_modules[@]}" )
- --enable-external-acl-helpers=$(print_options_without_comma "${ext_helpers[@]}" )
+ --enable-storeio=$(print_options_without_comma "${storeio_modules[@]}")
+ --enable-auth-basic=$(print_options_without_comma "${basic_modules[@]}")
+ --enable-auth-digest=$(print_options_without_comma "${digest_modules[@]}")
+ --enable-auth-ntlm=$(print_options_without_comma "${ntlm_modules[@]}")
+ --enable-auth-negotiate=$(print_options_without_comma "${negotiate_modules[@]}")
+ --enable-external-acl-helpers=$(print_options_without_comma "${ext_helpers[@]}")
)
econf "${myeconfargs[@]}"