summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2020-12-08 15:45:34 +0300
committerSergey Popov <pinkbyte@gentoo.org>2020-12-08 15:49:03 +0300
commit8135845b8bc6721e7537e46f7033537cf9ac30f6 (patch)
tree6ffcc1ab17db7091d63bd6d566d9ccfe470278bc /net-proxy/squidguard
parentdev-lang/luajit: fix Manifest (diff)
downloadgentoo-8135845b8bc6721e7537e46f7033537cf9ac30f6.tar.gz
gentoo-8135845b8bc6721e7537e46f7033537cf9ac30f6.tar.bz2
gentoo-8135845b8bc6721e7537e46f7033537cf9ac30f6.zip
net-proxy/squidguard: fix building with clang
Also correct build-time dependencies Reported-by: Agostino Sarubbo <ago@gentoo.org> Closes: https://bugs.gentoo.org/731680 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'net-proxy/squidguard')
-rw-r--r--net-proxy/squidguard/squidguard-1.6.0.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/net-proxy/squidguard/squidguard-1.6.0.ebuild b/net-proxy/squidguard/squidguard-1.6.0.ebuild
index c4bce1009a7e..a811dda736c4 100644
--- a/net-proxy/squidguard/squidguard-1.6.0.ebuild
+++ b/net-proxy/squidguard/squidguard-1.6.0.ebuild
@@ -24,9 +24,12 @@ RDEPEND="
)
ldap? ( net-nds/openldap:0 )"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+
+BDEPEND="
sys-devel/bison:0
- sys-devel/flex:0"
+ sys-devel/flex:0
+"
suitable_db_version() {
local tested_slots="5.3 4.8"
@@ -45,8 +48,12 @@ src_prepare() {
"${FILESDIR}/${P}-gcc-10.patch"
# Link only with specific BerkDB versions
+ # Do not inject default paths for library searching
db_version="$(suitable_db_version)"
- sed -i -e "/\$LIBS -ldb/s/-ldb/-l$(db_libname ${db_version})/" configure.ac || die
+ sed -i \
+ -e "/\$LIBS -ldb/s/-ldb/-l$(db_libname ${db_version})/" \
+ -e '/$LDFLAGS $db_lib $ldap_lib/d' \
+ configure.ac || die
eapply_user
eautoreconf