summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-proxy/torsocks/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-proxy/torsocks/files')
-rw-r--r--net-proxy/torsocks/files/avoid-pie-static.patch67
-rw-r--r--net-proxy/torsocks/files/fix-docdir-r2.patch21
-rw-r--r--net-proxy/torsocks/files/fix-docdir.patch24
-rw-r--r--net-proxy/torsocks/files/fix-find-libc.so.patch12
-rw-r--r--net-proxy/torsocks/files/suppress-warning-msgs.patch15
5 files changed, 139 insertions, 0 deletions
diff --git a/net-proxy/torsocks/files/avoid-pie-static.patch b/net-proxy/torsocks/files/avoid-pie-static.patch
new file mode 100644
index 000000000000..75565569b6e9
--- /dev/null
+++ b/net-proxy/torsocks/files/avoid-pie-static.patch
@@ -0,0 +1,67 @@
+We need to avoid tests which have -static and -pie together.
+
+See https://bugs.gentoo.org/show_bug.cgi?id=533862
+
+diff -Naur torsocks-2.0.0.orig/configure.ac torsocks-2.0.0/configure.ac
+--- torsocks-2.0.0.orig/configure.ac 2014-08-11 12:44:46.000000000 -0400
++++ torsocks-2.0.0/configure.ac 2015-01-11 12:00:21.174826622 -0500
+@@ -144,24 +144,6 @@
+ # Version information for libtorsocks
+ TORSOCKSLDFLAGS="$LDFLAGS -version-info 1:0:0"
+
+-# Check for the gcc hardening flags.
+-AX_CHECK_COMPILE_FLAG([-fPIE],[CFLAGS="$CFLAGS -fPIE"],[],[])
+-AX_CHECK_COMPILE_FLAG([-fwrapv],[CFLAGS="$CFLAGS -fwrapv"],[],[])
+-AX_CHECK_COMPILE_FLAG([--param ssp-buffer-size=1],
+- [CFLAGS="$CFLAGS --param ssp-buffer-size=1"],[],[])
+-AX_CHECK_COMPILE_FLAG([-fstack-protector-all],
+- [CFLAGS="$CFLAGS -fstack-protector-all"],[],[]
+-)
+-AX_CHECK_COMPILE_FLAG([-fno-strict-overflow],
+- [CFLAGS="$CFLAGS -fno-strict-overflow"],[],[]
+-)
+-
+-dnl Add hardening linker flags
+-AX_CHECK_LINK_FLAG([-pie],[LDFLAGS="$LDFLAGS -pie"],[],[])
+-AX_CHECK_LINK_FLAG([-z relro],[LDFLAGS="$LDFLAGS -z relro"],[],[])
+-AX_CHECK_LINK_FLAG([-z now],[LDFLAGS="$LDFLAGS -z now"],[],[])
+-LDFLAGS="$LDFLAGS -D_FORTIFY_SOURCE=2"
+-
+ dnl Linker checks for Mac OSX, which uses DYLD_INSERT_LIBRARIES
+ dnl instead of LD_PRELOAD
+ case "$host_os" in
+@@ -255,6 +237,34 @@
+ DEFAULT_INCLUDES="-I\$(top_srcdir) -I\$(top_builddir) -I\$(top_builddir)/src -I\$(top_builddir)/include -include config.h"
+ AC_SUBST(DEFAULT_INCLUDES)
+
++##############################################################################
++# 9. Test and add hardening flags
++##############################################################################
++
++# Check for the gcc hardening flags.
++AX_CHECK_COMPILE_FLAG([-fPIE],[CFLAGS="$CFLAGS -fPIE"],[],[])
++AX_CHECK_COMPILE_FLAG([-fwrapv],[CFLAGS="$CFLAGS -fwrapv"],[],[])
++AX_CHECK_COMPILE_FLAG([--param ssp-buffer-size=1],
++ [CFLAGS="$CFLAGS --param ssp-buffer-size=1"],[],[])
++AX_CHECK_COMPILE_FLAG([-fstack-protector-all],
++ [CFLAGS="$CFLAGS -fstack-protector-all"],[],[]
++)
++AX_CHECK_COMPILE_FLAG([-fno-strict-overflow],
++ [CFLAGS="$CFLAGS -fno-strict-overflow"],[],[]
++)
++
++dnl Add hardening linker flags
++AX_CHECK_LINK_FLAG([-pie],[LDFLAGS="$LDFLAGS -pie"],[],[])
++AX_CHECK_LINK_FLAG([-z relro],[LDFLAGS="$LDFLAGS -z relro"],[],[])
++AX_CHECK_LINK_FLAG([-z now],[LDFLAGS="$LDFLAGS -z now"],[],[])
++
++dnl Add glibc hardening
++CPPFLAGS="$CPPFLAGS -D_FORTIFY_SOURCE=2"
++
++##############################################################################
++# 10. Finish up
++##############################################################################
++
+ AC_CONFIG_FILES([
+ Makefile
+ extras/Makefile
diff --git a/net-proxy/torsocks/files/fix-docdir-r2.patch b/net-proxy/torsocks/files/fix-docdir-r2.patch
new file mode 100644
index 000000000000..05986ece2d0f
--- /dev/null
+++ b/net-proxy/torsocks/files/fix-docdir-r2.patch
@@ -0,0 +1,21 @@
+diff -Naur torsocks-2.0.0-rc2.orig/doc/Makefile.am torsocks-2.0.0-rc2/doc/Makefile.am
+--- torsocks-2.0.0-rc2.orig/doc/Makefile.am 2013-09-02 14:06:44.000000000 -0400
++++ torsocks-2.0.0-rc2/doc/Makefile.am 2013-09-17 14:19:37.769272561 -0400
+@@ -6,5 +6,5 @@
+ dist_man5_MANS = torsocks.conf.5
+ dist_man8_MANS = torsocks.8
+
+-dist_data_DATA = socks/SOCKS5 socks/socks-extensions.txt notes/DEBUG
++#dist_data_DATA = socks/SOCKS5 socks/socks-extensions.txt notes/DEBUG
+
+diff -Naur torsocks-2.0.0-rc2.orig/Makefile.am torsocks-2.0.0-rc2/Makefile.am
+--- torsocks-2.0.0-rc2.orig/Makefile.am 2013-09-02 14:06:44.000000000 -0400
++++ torsocks-2.0.0-rc2/Makefile.am 2013-09-17 14:20:07.945273935 -0400
+@@ -2,6 +2,6 @@
+
+ SUBDIRS = src doc tests
+
+-dist_doc_DATA = ChangeLog
++#dist_doc_DATA = ChangeLog
+
+ EXTRA_DIST = gpl-2.0.txt
diff --git a/net-proxy/torsocks/files/fix-docdir.patch b/net-proxy/torsocks/files/fix-docdir.patch
new file mode 100644
index 000000000000..899c15b16721
--- /dev/null
+++ b/net-proxy/torsocks/files/fix-docdir.patch
@@ -0,0 +1,24 @@
+diff -Naur torsocks-1.2.orig/doc/Makefile.am torsocks-1.2/doc/Makefile.am
+--- torsocks-1.2.orig/doc/Makefile.am 2011-10-26 14:30:26.000000000 -0400
++++ torsocks-1.2/doc/Makefile.am 2011-12-26 20:05:40.000000000 -0500
+@@ -7,8 +7,6 @@
+ # Install man pages
+ dist_man_MANS = torsocks.1 torsocks.8 usewithtor.1 torsocks.conf.5
+
+-dist_data_DATA = socks/SOCKS5 socks/SOCKS4.protocol socks/socks-extensions.txt \
+- patches/compilewarnings.patch patches/conffile.patch patches/getaddrbyhost.patch \
+- patches/getpeername.patch patches/infiniteloop.patch patches/localaddresses.patch \
+- patches/README patches/README.TORDNS patches/tordns.patch notes/DEBUG
++dist_doc_DATA = socks/SOCKS5 socks/SOCKS4.protocol socks/socks-extensions.txt \
++ notes/DEBUG
+
+diff -Naur torsocks-1.2.orig/test/Makefile.am torsocks-1.2/test/Makefile.am
+--- torsocks-1.2.orig/test/Makefile.am 2011-10-26 14:21:57.000000000 -0400
++++ torsocks-1.2/test/Makefile.am 2011-12-26 20:04:34.000000000 -0500
+@@ -4,4 +4,4 @@
+ test_torsocks_LDFLAGS= $(TESTLDFLAGS)
+ CLEANFILES= test_torsocks
+
+-dist_data_DATA = run_tests.sh expectedresults.txt
+\ No newline at end of file
++dist_doc_DATA = run_tests.sh expectedresults.txt
diff --git a/net-proxy/torsocks/files/fix-find-libc.so.patch b/net-proxy/torsocks/files/fix-find-libc.so.patch
new file mode 100644
index 000000000000..0fb1949116e1
--- /dev/null
+++ b/net-proxy/torsocks/files/fix-find-libc.so.patch
@@ -0,0 +1,12 @@
+diff -Nuar torsocks-2.0.0-rc3.orig/configure.ac torsocks-2.0.0-rc3/configure.ac
+--- torsocks-2.0.0-rc3.orig/configure.ac 2013-11-03 13:24:51.000000000 -0500
++++ torsocks-2.0.0-rc3/configure.ac 2014-01-26 12:49:55.157606016 -0500
+@@ -132,7 +132,7 @@
+ dnl Get libc full system path. Use prefix or some hardcoded standard
+ dnl location on Unixish system.
+ AC_MSG_CHECKING(location of libc.so)
+-for DIR in "$prefix/lib" "$prefix/usr/lib" '/lib' '/usr/lib'; do
++for DIR in "$prefix/lib*" "$prefix/usr/lib*" '/lib*' '/usr/lib*'; do
+ if test "${LIBC_PATH}" = ""; then
+ LIBC_PATH=`$FIND $DIR -name "libc.so.?" 2>/dev/null | $TAIL -1`
+ fi
diff --git a/net-proxy/torsocks/files/suppress-warning-msgs.patch b/net-proxy/torsocks/files/suppress-warning-msgs.patch
new file mode 100644
index 000000000000..7470b9fa7f4b
--- /dev/null
+++ b/net-proxy/torsocks/files/suppress-warning-msgs.patch
@@ -0,0 +1,15 @@
+--- torsocks-1.2.orig/src/torsocks.c 2011-10-25 17:49:50.000000000 -0400
++++ torsocks-1.2/src/torsocks.c 2012-02-21 11:09:20.000000000 -0500
+@@ -124,9 +124,9 @@
+ #define LOAD_ERROR(s,l) { \
+ const char *error; \
+ error = dlerror(); \
+- show_msg(l, "The symbol %s() was not found in any shared " \
+- "library. The error reported was: %s!\n", s, \
+- (error)?error:"not found"); \
++ if (error) \
++ show_msg(l, "The symbol %s() was not found in any shared " \
++ "library. The error reported was: %s!\n", s, error); \
+ dlerror(); \
+ }
+ pthread_mutex_lock(&torsocks_init_mutex);