summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYangMame <yangmame@icloud.com>2019-10-06 09:49:52 +0800
committerJoonas Niilola <juippis@gentoo.org>2019-12-15 10:20:47 +0200
commit2529f7ca531918b7d215a9975fcd17c23b637f77 (patch)
tree8fa7eb01ad5f9bd5c6babca827666e4d6b456299 /net-proxy/trojan/trojan-1.13.0.ebuild
parentwww-apps/redmine: fixing dependencies (diff)
downloadgentoo-2529f7ca531918b7d215a9975fcd17c23b637f77.tar.gz
gentoo-2529f7ca531918b7d215a9975fcd17c23b637f77.tar.bz2
gentoo-2529f7ca531918b7d215a9975fcd17c23b637f77.zip
net-proxy/trojan: version bump to 1.13.0
Signed-off-by: Xin Yang <yangmame@icloud.com> Closes: https://github.com/gentoo/gentoo/pull/13182 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-proxy/trojan/trojan-1.13.0.ebuild')
-rw-r--r--net-proxy/trojan/trojan-1.13.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-proxy/trojan/trojan-1.13.0.ebuild b/net-proxy/trojan/trojan-1.13.0.ebuild
new file mode 100644
index 000000000000..02b78af04256
--- /dev/null
+++ b/net-proxy/trojan/trojan-1.13.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+
+inherit cmake-utils python-any-r1 systemd
+
+DESCRIPTION="An unidentifiable mechanism that helps you bypass GFW"
+HOMEPAGE="https://github.com/trojan-gfw/trojan"
+SRC_URI="https://github.com/trojan-gfw/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="mysql test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/boost-1.66.0:=
+ dev-libs/openssl:0=
+ mysql? ( dev-db/mysql-connector-c:= )
+"
+DEPEND="${RDEPEND}
+ test? ( net-misc/curl ${PYTHON_DEPS} )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_MYSQL=$(usex mysql)
+ -DSYSTEMD_SERVICE=ON
+ -DSYSTEMD_SERVICE_PATH=$(systemd_get_systemunitdir)
+ -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newinitd "${FILESDIR}/trojan.initd" trojan
+}
+
+src_test() {
+ cmake-utils_src_test -j1
+}