summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-04-17 20:57:43 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-04-17 21:19:37 +0200
commit2acde7b9b35942d9f4f414cb5f0ffe8bfff774c9 (patch)
tree9111a0966995b2d1f8f1ff411e542ede29129e1b /net-proxy
parentnet-proxy/cntlm: drop old version (diff)
downloadgentoo-2acde7b9b35942d9f4f414cb5f0ffe8bfff774c9.tar.gz
gentoo-2acde7b9b35942d9f4f414cb5f0ffe8bfff774c9.tar.bz2
gentoo-2acde7b9b35942d9f4f414cb5f0ffe8bfff774c9.zip
net-proxy/havp: migrate to glep 81
Closes: https://bugs.gentoo.org/781464 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/havp/havp-0.92a-r3.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/net-proxy/havp/havp-0.92a-r3.ebuild b/net-proxy/havp/havp-0.92a-r3.ebuild
new file mode 100644
index 000000000000..e29ca2eab914
--- /dev/null
+++ b/net-proxy/havp/havp-0.92a-r3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="HTTP AntiVirus Proxy"
+HOMEPAGE="http://www.server-side.de/"
+SRC_URI="http://www.server-side.de/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="clamav ssl"
+
+DEPEND="clamav? ( >=app-antivirus/clamav-0.98.5 )"
+RDEPEND="
+ ${DEPEND}
+ acct-group/havp
+ acct-user/havp
+"
+
+PATCHES=(
+ "${FILESDIR}"/havp-0.92a-run.patch
+ "${FILESDIR}"/${P}-pkg-config-libclamav.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i configure.in -e '/^CFLAGS=/d' || die
+ mv configure.{in,ac} || die
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export AR
+ export CFLAGS="${CXXFLAGS}"
+
+ local myeconfargs=(
+ $(use_enable clamav)
+ $(use_enable ssl ssl-tunnel)
+ --localstatedir=/var
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ dosbin havp/havp
+
+ newinitd "${FILESDIR}/havp.initd" havp
+
+ rm -r etc/havp/havp.config.in || die
+ insinto /etc
+ doins -r etc/havp
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ ewarn "/var/tmp/havp must be on a filesystem with mandatory locks!"
+ ewarn "You should add \"mand\" to the mount options on the relevant line in /etc/fstab."
+
+ if use ssl; then
+ echo
+ ewarn "Note: ssl USE flag only enable SSL pass-through, which means that"
+ ewarn " HTTPS pages will not be scanned for viruses!"
+ ewarn " It is impossible to decrypt data sent through SSL connections without knowing"
+ ewarn " the private key of the used certificate."
+ fi
+
+ if use clamav; then
+ echo
+ ewarn "If you plan to use clamav daemon, you should make sure clamav user can read"
+ ewarn "/var/tmp/havp content. This can be accomplished by enabling AllowSupplementaryGroups"
+ ewarn "in /etc/clamd.conf and adding clamav user to the havp group."
+ fi
+}