summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-04-17 20:50:58 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-04-17 21:19:35 +0200
commit6db97a29e135e71a1425be553b2240b1a0db2c7c (patch)
treed0704f33e6804cf8c096671bdf8d450c9910b151 /net-proxy
parentnet-p2p/litecoind: drop old version (diff)
downloadgentoo-6db97a29e135e71a1425be553b2240b1a0db2c7c.tar.gz
gentoo-6db97a29e135e71a1425be553b2240b1a0db2c7c.tar.bz2
gentoo-6db97a29e135e71a1425be553b2240b1a0db2c7c.zip
net-proxy/cntlm: migrate to glep 81
Closes: https://bugs.gentoo.org/781458 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/cntlm/cntlm-0.93_beta5-r3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-proxy/cntlm/cntlm-0.93_beta5-r3.ebuild b/net-proxy/cntlm/cntlm-0.93_beta5-r3.ebuild
new file mode 100644
index 000000000000..4c6879ddacc1
--- /dev/null
+++ b/net-proxy/cntlm/cntlm-0.93_beta5-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Cntlm is an NTLM/NTLMv2 authenticating HTTP proxy"
+HOMEPAGE="http://cntlm.sourceforge.net/"
+SRC_URI="http://ftp.awk.cz/pub/${P//_}.tar.gz"
+S="${WORKDIR}/${P//_}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ acct-group/cntlm
+ acct-user/cntlm
+"
+
+src_prepare() {
+ default
+ eapply -p0 "${FILESDIR}"/${P}-buildsystem.patch # 334647
+}
+
+src_configure() {
+ tc-export CC
+
+ econf
+
+ # Replace default config file path in Makefile
+ sed -e 's~SYSCONFDIR=/usr/local/etc~SYSCONFDIR=/etc~' -i "${S}"/Makefile || die
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ dobin cntlm
+ dodoc COPYRIGHT README VERSION doc/cntlm.conf
+ doman doc/cntlm.1
+ newinitd "${FILESDIR}"/cntlm.initd cntlm
+ newconfd "${FILESDIR}"/cntlm.confd cntlm
+ systemd_dounit "${FILESDIR}"/cntlm.service
+ insinto /etc
+ insopts -m0600
+ doins doc/cntlm.conf
+}