summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2018-10-09 07:58:04 -0500
committerBen Kohler <bkohler@gentoo.org>2018-10-09 08:06:37 -0500
commitfeac52e03f0da8af3295b02671607affd596995e (patch)
tree8425ed920fb63c2f896121f80529d231611efd55 /net-proxy
parentnet-proxy/tinyproxy: add myself as maintainer (diff)
downloadgentoo-feac52e03f0da8af3295b02671607affd596995e.tar.gz
gentoo-feac52e03f0da8af3295b02671607affd596995e.tar.bz2
gentoo-feac52e03f0da8af3295b02671607affd596995e.zip
net-proxy/tinyproxy: bump to 1.8.4
Signed-off-by: Ben Kohler <bkohler@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/tinyproxy/Manifest1
-rw-r--r--net-proxy/tinyproxy/files/tinyproxy-1.8.3-r2.initd2
-rw-r--r--net-proxy/tinyproxy/tinyproxy-1.8.3-r4.ebuild2
-rw-r--r--net-proxy/tinyproxy/tinyproxy-1.8.4.ebuild85
4 files changed, 88 insertions, 2 deletions
diff --git a/net-proxy/tinyproxy/Manifest b/net-proxy/tinyproxy/Manifest
index 84b24942b149..1e6308bec831 100644
--- a/net-proxy/tinyproxy/Manifest
+++ b/net-proxy/tinyproxy/Manifest
@@ -1 +1,2 @@
DIST tinyproxy-1.8.3.tar.bz2 202430 BLAKE2B 1f85d6eb3a1b2cebe752f15e51869882c58f7dcafb2518511dd8c83c44a010a1cdac93e40e2c1f177a7687b126925258c79ff56011a42addd710b2009d546313 SHA512 69f1262b39d37f44a42621a0d25985632cdb790c8d9b49335a49a68c0f5237b97b111252856cba119895ac066770645560d2d7cd2de31f02103fa55fb4b3290c
+DIST tinyproxy-1.8.4.tar.xz 192300 BLAKE2B bc425ab40d5d5fb49111d74d67e7ac848d77ad4be87039b34543a118df317839aa529c6b9ca52f1eafe933e7d344e09770a76ed0184181591483c6b3f1d79243 SHA512 23398a2c8a6d926b371086ba96032d0fd8dd06d114edf24950b868f53bb6b4235cd0f5d6b9a0131879fcc16bbe6b71142a6855de593a937ef7b0c323b50e0aec
diff --git a/net-proxy/tinyproxy/files/tinyproxy-1.8.3-r2.initd b/net-proxy/tinyproxy/files/tinyproxy-1.8.3-r2.initd
index 9df4ef5046d7..0d6618b69a9a 100644
--- a/net-proxy/tinyproxy/files/tinyproxy-1.8.3-r2.initd
+++ b/net-proxy/tinyproxy/files/tinyproxy-1.8.3-r2.initd
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
get_config() {
diff --git a/net-proxy/tinyproxy/tinyproxy-1.8.3-r4.ebuild b/net-proxy/tinyproxy/tinyproxy-1.8.3-r4.ebuild
index 9f8aa70a55f5..c371c7b1b9ea 100644
--- a/net-proxy/tinyproxy/tinyproxy-1.8.3-r4.ebuild
+++ b/net-proxy/tinyproxy/tinyproxy-1.8.3-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
diff --git a/net-proxy/tinyproxy/tinyproxy-1.8.4.ebuild b/net-proxy/tinyproxy/tinyproxy-1.8.4.ebuild
new file mode 100644
index 000000000000..527258737691
--- /dev/null
+++ b/net-proxy/tinyproxy/tinyproxy-1.8.4.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools systemd tmpfiles user
+
+DESCRIPTION="A lightweight HTTP/SSL proxy"
+HOMEPAGE="https://github.com/tinyproxy/tinyproxy/"
+SRC_URI="https://github.com/tinyproxy/tinyproxy/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="test debug +filter-proxy minimal reverse-proxy
+ transparent-proxy +upstream-proxy +xtinyproxy-header"
+
+REQUIRED_USE="test? ( xtinyproxy-header )"
+
+DEPEND="!minimal? ( app-text/asciidoc )"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} "" "" "" ${PN}
+}
+
+src_prepare() {
+ use minimal && PATCHES+=( "${FILESDIR}/${PN}-1.8.1-minimal.patch" )
+
+ default
+
+ sed -i \
+ -e "s|nobody|${PN}|g" \
+ -e 's|/var/run/|/run/|g' \
+ etc/${PN}.conf.in || die "sed failed"
+
+ sed -i \
+ -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ if use minimal; then
+ ln -s /bin/true "${T}"/a2x
+ export PATH="${T}:${PATH}"
+ fi
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable filter-proxy filter) \
+ $(use_enable reverse-proxy reverse) \
+ $(use_enable transparent-proxy transparent) \
+ $(use_enable upstream-proxy upstream) \
+ $(use_enable xtinyproxy-header xtinyproxy) \
+ --disable-silent-rules \
+ --localstatedir=/var
+}
+
+src_test() {
+ # The make check target does not run the test suite
+ emake test
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ diropts -m0775 -o ${PN} -g ${PN}
+ keepdir /var/log/${PN}
+
+ newinitd "${FILESDIR}"/${PN}-1.8.3-r2.initd tinyproxy
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_dotmpfilesd "${FILESDIR}"/${PN}.tmpfiles.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.tmpfiles.conf
+
+ elog "For filtering domains and URLs, enable filter option in the configuration"
+ elog "file and add them to the filter file (one domain or URL per line)."
+}