summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-27 06:15:51 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-27 08:16:55 +0200
commit600e33d66bc80bfdc9f55dfae027f5c8a6d94ef9 (patch)
treee3a0abfa1ddefc3a82b9d2073e6ed9a5ecc94843 /net-voip
parentdev-ruby/simplecov-html: add 0.12.3 (diff)
downloadgentoo-600e33d66bc80bfdc9f55dfae027f5c8a6d94ef9.tar.gz
gentoo-600e33d66bc80bfdc9f55dfae027f5c8a6d94ef9.tar.bz2
gentoo-600e33d66bc80bfdc9f55dfae027f5c8a6d94ef9.zip
net-voip/telepathy-rakia: Port to py3 / any-r1
Backport a py3 compat patch and correct the package to use python-any-r1 as it does not seem to install anything Python. Closes: https://bugs.gentoo.org/735434 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/telepathy-rakia/Manifest1
-rw-r--r--net-voip/telepathy-rakia/telepathy-rakia-0.8.0-r1.ebuild (renamed from net-voip/telepathy-rakia/telepathy-rakia-0.8.0.ebuild)21
2 files changed, 13 insertions, 9 deletions
diff --git a/net-voip/telepathy-rakia/Manifest b/net-voip/telepathy-rakia/Manifest
index ac9c3d861c69..ca1cb26dff46 100644
--- a/net-voip/telepathy-rakia/Manifest
+++ b/net-voip/telepathy-rakia/Manifest
@@ -1 +1,2 @@
+DIST telepathy-rakia-0.8.0-py3.patch 4472 BLAKE2B 6eb45f91f351ba6ee0afa16022921efaa764168acf9a0891b57cba4ab90c5f2f3f58c7704ecc7224d9aa1a9559a6be7b96cb8ab3c5382552fe2d640ecfd94ab5 SHA512 cf76d730001da55e1bececbfab9810c83643c6b4cabc6c92c106fafae8a64d75b2eaa455599d70a0e40f13ea6d293f0621948e3a3d047d4002ce3b08b58858f0
DIST telepathy-rakia-0.8.0.tar.gz 659116 BLAKE2B b940d28828220f83c3408aeb9effc26f17d62729f01073539ca4381604bc762b411064d6de92a557ff0f7a8a1920799163f6ede2dba6cfec01967145501a1da2 SHA512 5378e1a2909c4218cc9c6fecf0b01beff0b52fd40cc040a601090dbaae330b3506fc74dc5ae86e5f0c954dd3c41fd7ba4e5a294f8fc11d74aa6eb9025097e9ae
diff --git a/net-voip/telepathy-rakia/telepathy-rakia-0.8.0.ebuild b/net-voip/telepathy-rakia/telepathy-rakia-0.8.0-r1.ebuild
index 93507fcb9416..e6a644508e34 100644
--- a/net-voip/telepathy-rakia/telepathy-rakia-0.8.0.ebuild
+++ b/net-voip/telepathy-rakia/telepathy-rakia-0.8.0-r1.ebuild
@@ -1,25 +1,24 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6..9} )
-inherit python-single-r1
+inherit python-any-r1
DESCRIPTION="A SIP connection manager for Telepathy based around the Sofia-SIP library"
HOMEPAGE="https://telepathy.freedesktop.org/"
-SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz
+ https://patch-diff.githubusercontent.com/raw/TelepathyIM/telepathy-rakia/pull/1.patch
+ -> ${P}-py3.patch"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test"
COMMON_DEPEND="
- ${PYTHON_DEPS}
>=dev-libs/dbus-glib-0.60
>=dev-libs/glib-2.30:2
>=net-libs/sofia-sip-1.12.11
@@ -31,11 +30,15 @@ RDEPEND="${COMMON_DEPEND}
"
# telepathy-rakia was formerly known as telepathy-sofiasip
DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
dev-libs/libxslt
- test? ( dev-python/twisted-core )
"
# eautoreconf requires: gtk-doc-am
+PATCHES=(
+ "${DISTDIR}"/${P}-py3.patch
+)
+
src_configure() {
econf --disable-fatal-warnings
}