summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-15 20:25:08 +0000
committerSam James <sam@gentoo.org>2020-09-15 20:51:42 +0000
commitddb0a09e7596a165240be2f0299f91be5a366ab4 (patch)
tree1c393e8871e4e529036d8b07c9233a52df5be101 /net-vpn/httptunnel
parentnet-vpn/httptunnel: bump to EAPI 7 (diff)
downloadgentoo-ddb0a09e7596a165240be2f0299f91be5a366ab4.tar.gz
gentoo-ddb0a09e7596a165240be2f0299f91be5a366ab4.tar.bz2
gentoo-ddb0a09e7596a165240be2f0299f91be5a366ab4.zip
net-vpn/httptunnel: bump to 20180119 snapshot
* Includes various Debian patches * Respect AR Closes: https://bugs.gentoo.org/725216 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-vpn/httptunnel')
-rw-r--r--net-vpn/httptunnel/Manifest1
-rw-r--r--net-vpn/httptunnel/files/httptunnel-3.3_p20180119-respect-AR.patch12
-rw-r--r--net-vpn/httptunnel/httptunnel-3.3_p20180119.ebuild27
3 files changed, 40 insertions, 0 deletions
diff --git a/net-vpn/httptunnel/Manifest b/net-vpn/httptunnel/Manifest
index 4f352da15378..0b93ad67deba 100644
--- a/net-vpn/httptunnel/Manifest
+++ b/net-vpn/httptunnel/Manifest
@@ -1 +1,2 @@
DIST httptunnel-3.3.tar.gz 262749 BLAKE2B d16c06f709befd45e13ac8f13c13242c90d045a23cbb6f39b8d8355d5a9e56643bb7766d4d8ae6dece16686d555850fa4a0e682fc9bb3e33ec7a5144311e517b SHA512 84503e27e84cd39441a7592d6446e30fce07a54b940e4398407dc105fabc6c8f96d3b5d05137d6dab22b2088c5b114728551337429748c900bd6fe7d6b6109e5
+DIST httptunnel-3.3_p20180119.tar.gz 376338 BLAKE2B 6625a0ef0bef7afad4ca9b5791abe51d72553877c31dfcb4e4d0bfd6d0e3bf3a0a9f7c529db6a9f9c60726e7e79284959ed8a8bf64e1165e40265341f39cbaf6 SHA512 593efe9ebdc3c41338306e5038cacd63ec171d228ebf13ba52949c353b1d45666bc836ce34102735a383b6cc91f2df1c01e87c2ab1cf5e650fe5fe7fcc658de0
diff --git a/net-vpn/httptunnel/files/httptunnel-3.3_p20180119-respect-AR.patch b/net-vpn/httptunnel/files/httptunnel-3.3_p20180119-respect-AR.patch
new file mode 100644
index 000000000000..bdc6b7fb5a4a
--- /dev/null
+++ b/net-vpn/httptunnel/files/httptunnel-3.3_p20180119-respect-AR.patch
@@ -0,0 +1,12 @@
+diff --git a/configure.ac b/configure.ac
+index acd5843..f5ad65d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -26,6 +26,7 @@ AC_PROG_CC
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_RANLIB
++AM_PROG_AR
+
+ dnl Checks for libraries.
+ AC_CHECK_FUNC([gethostent], :, [AC_CHECK_LIB(nsl, gethostent)])
diff --git a/net-vpn/httptunnel/httptunnel-3.3_p20180119.ebuild b/net-vpn/httptunnel/httptunnel-3.3_p20180119.ebuild
new file mode 100644
index 000000000000..c22f99897765
--- /dev/null
+++ b/net-vpn/httptunnel/httptunnel-3.3_p20180119.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+COMMIT="f440dcb3c341d22428898952c343ad9fa6e9e7f5"
+DESCRIPTION="httptunnel can create IP tunnels through firewalls/proxies using HTTP"
+HOMEPAGE="https://github.com/larsbrinkhoff/httptunnel"
+SRC_URI="https://github.com/larsbrinkhoff/httptunnel/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.3_p20180119-respect-AR.patch"
+)
+
+src_prepare() {
+ default
+
+ tc-export AR RANLIB
+ eautoreconf
+}