summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Korepanov <kaikaikai@yandex.ru>2021-11-29 15:18:47 +0000
committerIonen Wolkens <ionen@gentoo.org>2021-12-01 00:49:17 -0500
commit4c22daa1cab466a0d764c30ab04ae6afa1df74e4 (patch)
treefa56a3424f2baa69359b4c23c57fc96834bb8296 /net-vpn/i2pd
parentvirtual/mpi: Stabilize 2.0-r5 ppc, #811852 (diff)
downloadgentoo-4c22daa1cab466a0d764c30ab04ae6afa1df74e4.tar.gz
gentoo-4c22daa1cab466a0d764c30ab04ae6afa1df74e4.tar.bz2
gentoo-4c22daa1cab466a0d764c30ab04ae6afa1df74e4.zip
net-vpn/i2pd: version bump 2.40.0
ionen's note: tested and confirming openssl-3.0.0 works wrt #806166 Closes: https://bugs.gentoo.org/806166 Signed-off-by: Alexey Korepanov <kaikaikai@yandex.ru> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-vpn/i2pd')
-rw-r--r--net-vpn/i2pd/Manifest1
-rw-r--r--net-vpn/i2pd/i2pd-2.40.0.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/net-vpn/i2pd/Manifest b/net-vpn/i2pd/Manifest
index 055ce2cb5c5c..6ad053b5a959 100644
--- a/net-vpn/i2pd/Manifest
+++ b/net-vpn/i2pd/Manifest
@@ -1 +1,2 @@
DIST i2pd-2.39.0.tar.gz 579825 BLAKE2B 14f4167fd7752529f513f89cf9d08fd9dbf086f9336c5dae47ef30fa81a753c955de7e622131214f6924a7af8fb62e6a3b5b59c8ae0d407ed7305c3c6dc8a692 SHA512 6b38e6e2e763e94ffe9d11eb2f9a0e9554560bb4fec95891240adf5bc0a9639f879dac4ff3712a9f8e00895b7bbeabc854887e61fe9f9755c33f96899e20aa76
+DIST i2pd-2.40.0.tar.gz 587626 BLAKE2B 80433580f3db5969f0f30bac420104a29995c0f32ed738d64d079854892a1f70876ab9180fbe8269ccb6b91474f786c834dc08e71a2cad81307a8b54fdda8888 SHA512 58d10417f3fd2c2fb427fb88b30ccd3e03053c84aa7ac6d3e346c388f2376d1768846bec5ee8d5134dd62d5712b20f890af11083634f94095b1117f6494c25fd
diff --git a/net-vpn/i2pd/i2pd-2.40.0.ebuild b/net-vpn/i2pd/i2pd-2.40.0.ebuild
new file mode 100644
index 000000000000..508b3c4ca5e7
--- /dev/null
+++ b/net-vpn/i2pd/i2pd-2.40.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs systemd
+
+DESCRIPTION="A C++ daemon for accessing the I2P anonymous network"
+HOMEPAGE="https://github.com/PurpleI2P/i2pd"
+SRC_URI="https://github.com/PurpleI2P/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cpu_flags_x86_aes cpu_flags_x86_avx i2p-hardening +upnp"
+
+RDEPEND="
+ acct-user/i2pd
+ acct-group/i2pd
+ dev-libs/boost:=[threads(+)]
+ dev-libs/openssl:0=[-bindist(-)]
+ sys-libs/zlib
+ upnp? ( net-libs/miniupnpc:= )"
+DEPEND="${RDEPEND}"
+
+CMAKE_USE_DIR="${S}/build"
+
+DOCS=( "${S}/README.md" "${S}/contrib/i2pd.conf" "${S}/contrib/tunnels.conf" )
+
+pkg_pretend() {
+ if use i2p-hardening && ! tc-is-gcc; then
+ die "i2p-hardening requires gcc"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_AESNI=$(usex cpu_flags_x86_aes ON OFF)
+ -DWITH_HARDENING=$(usex i2p-hardening ON OFF)
+ -DWITH_PCH=OFF
+ -DWITH_STATIC=OFF
+ -DWITH_UPNP=$(usex upnp ON OFF)
+ -DWITH_LIBRARY=ON
+ -DWITH_BINARY=ON
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # config
+ insinto /etc/i2pd
+ doins contrib/i2pd.conf
+ doins contrib/tunnels.conf
+
+ # working directory
+ insinto /var/lib/i2pd
+ doins -r contrib/certificates
+
+ # add /var/lib/i2pd/certificates to CONFIG_PROTECT
+ doenvd "${FILESDIR}/99i2pd"
+
+ # openrc and systemd daemon routines
+ newconfd "${FILESDIR}/i2pd-2.6.0-r3.confd" i2pd
+ newinitd "${FILESDIR}/i2pd-2.39.0.initd" i2pd
+ systemd_newunit "${FILESDIR}/i2pd-2.38.0.service" i2pd.service
+
+ # logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/i2pd-2.38.0-r1.logrotate" i2pd
+}
+
+pkg_postinst() {
+ if [[ -f ${EROOT}/etc/i2pd/subscriptions.txt ]]; then
+ ewarn
+ ewarn "Configuration of the subscriptions has been moved from"
+ ewarn "subscriptions.txt to i2pd.conf. We recommend updating"
+ ewarn "i2pd.conf accordingly and deleting subscriptions.txt."
+ fi
+}