summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2020-03-28 09:28:03 +0100
committerJohannes Huber <johu@gentoo.org>2020-03-28 09:28:03 +0100
commit7e5ea44f7b0a08797db2da56e796498db09c55aa (patch)
treee98c2dd47c7872af025d0e9b8d1a9bf48d10a4dd /net-vpn/openfortivpn
parentprofiles: Force USE=ssl for net-misc/wget (diff)
downloadgentoo-7e5ea44f7b0a08797db2da56e796498db09c55aa.tar.gz
gentoo-7e5ea44f7b0a08797db2da56e796498db09c55aa.tar.bz2
gentoo-7e5ea44f7b0a08797db2da56e796498db09c55aa.zip
net-vpn/openfortivpn: Version bump 1.13.2
Bug: https://bugs.gentoo.org/711018 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'net-vpn/openfortivpn')
-rw-r--r--net-vpn/openfortivpn/Manifest1
-rw-r--r--net-vpn/openfortivpn/openfortivpn-1.13.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-vpn/openfortivpn/Manifest b/net-vpn/openfortivpn/Manifest
index 0289e10156fe..b89b1a4ddc23 100644
--- a/net-vpn/openfortivpn/Manifest
+++ b/net-vpn/openfortivpn/Manifest
@@ -1 +1,2 @@
DIST openfortivpn-1.11.0.tar.gz 77325 BLAKE2B af899a0e096f439fd85bf65d5a6bf620fd970177ab2afbf4b4bcfec6fdd34179ec7e239ceadcf0fe326c8eb9d281e7c19756e2ea444e96c58a203f0c32795163 SHA512 09a1d2deea932be80306a2a394aae8553e23389668844dd16d69626bdf1e6c28f58c0d45483fbb994b046e4e4cce4bf6e1e79fcd3ebc2c4d93870f431a8553f4
+DIST openfortivpn-1.13.2.tar.gz 82977 BLAKE2B 5daf2fdacaf2f9c3bc0a4bc3fc26543ed0ab424b70d2795e7b3d74b38cba53b1a8a9823564198ea5292b63f872c12f17ed3f65111a7024faee19640fff765cd7 SHA512 6be456784618d0af26190bad4af20a5f7163d3d984e3317fa3aac04b605ddd39f8973b192cf35fc8a371bf5ca4cbff8f644991b0cc031f558bf7881066fe8ec2
diff --git a/net-vpn/openfortivpn/openfortivpn-1.13.2.ebuild b/net-vpn/openfortivpn/openfortivpn-1.13.2.ebuild
new file mode 100644
index 000000000000..2cda60426dcc
--- /dev/null
+++ b/net-vpn/openfortivpn/openfortivpn-1.13.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info
+
+DESCRIPTION="Fortinet compatible VPN client"
+HOMEPAGE="https://github.com/adrienverge/openfortivpn"
+SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl"
+
+DEPEND="
+ net-dialup/ppp
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~PPP ~PPP_ASYNC"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ keepdir /etc/openfortivpn
+}