summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-06 15:51:35 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-06 15:55:01 +0200
commitec756ba52bd6eed0033fadfdd332aec9dfe343bd (patch)
tree79d1134dc219607b10a13667c2c0e513dfe17298 /net-vpn/riseup-vpn
parentmedia-video/droidcam: support Clang and Clang+LTO built kernels OOTB (diff)
downloadgentoo-ec756ba52bd6eed0033fadfdd332aec9dfe343bd.tar.gz
gentoo-ec756ba52bd6eed0033fadfdd332aec9dfe343bd.tar.bz2
gentoo-ec756ba52bd6eed0033fadfdd332aec9dfe343bd.zip
net-vpn/riseup-vpn: fix parallel make
See Also: https://0xacab.org/leap/bitmask-vpn/-/merge_requests/146 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-vpn/riseup-vpn')
-rw-r--r--net-vpn/riseup-vpn/files/riseup-vpn-parallel-make.patch54
-rw-r--r--net-vpn/riseup-vpn/riseup-vpn-0.21.6-r1.ebuild7
2 files changed, 58 insertions, 3 deletions
diff --git a/net-vpn/riseup-vpn/files/riseup-vpn-parallel-make.patch b/net-vpn/riseup-vpn/files/riseup-vpn-parallel-make.patch
new file mode 100644
index 000000000000..2b0f188e4a57
--- /dev/null
+++ b/net-vpn/riseup-vpn/files/riseup-vpn-parallel-make.patch
@@ -0,0 +1,54 @@
+diff --git a/Makefile b/Makefile
+index b9ddda5..500adb7 100644
+--- a/Makefile
++++ b/Makefile
+@@ -108,7 +108,7 @@ PKGFILES = $(shell find pkg -type f -name '*.go')
+ endif
+
+ lib/%.a: $(PKGFILES)
+- @XBUILD=no ./gui/build.sh --just-golib
++ @XBUILD=no MAKE=${MAKE} ./gui/build.sh --just-golib
+
+ relink_vendor:
+ @echo "============RELINK VENDOR============="
+@@ -136,14 +136,14 @@ endif
+
+ build_golib: lib/libgoshim.a
+
+-build_gui: relink_vendor
++build_gui: build_golib relink_vendor
+ @echo "==============BUILD GUI==============="
+ @echo "TARGET: ${TARGET}"
+ @echo "VENDOR_PATH: ${VENDOR_PATH}"
+- @XBUILD=no QMAKE=${QMAKE} LRELEASE=${LRELEASE} TARGET=${TARGET} VENDOR_PATH=${VENDOR_PATH} gui/build.sh --skip-golib
++ @XBUILD=no MAKE=${MAKE} QMAKE=${QMAKE} LRELEASE=${LRELEASE} TARGET=${TARGET} VENDOR_PATH=${VENDOR_PATH} gui/build.sh --skip-golib
+ @echo "============BUILD GUI================="
+
+-build: build_golib build_helper build_gui
++build: build_helper build_gui
+
+ build_helper:
+ ifeq ($(PLATFORM), linux)
+diff --git a/gui/build.sh b/gui/build.sh
+index 9e519a6..8aa0356 100755
+--- a/gui/build.sh
++++ b/gui/build.sh
+@@ -17,6 +17,7 @@ PROJECT=bitmask.pro
+ TARGET_GOLIB=lib/libgoshim.a
+ SOURCE_GOLIB=gui/backend.go
+
++MAKE=${MAKE:=make}
+ QTBUILD=build/qt
+ RELEASE=$QTBUILD/release
+ DEBUGP=$QTBUILD/debug
+@@ -114,8 +115,8 @@ function buildDefault {
+ fi
+ buildQmake
+
+- make -C $QTBUILD clean
+- make -C $QTBUILD $MAKEFLAGS all
++ $MAKE -C $QTBUILD clean
++ $MAKE -C $QTBUILD $MAKEFLAGS all
+
+ renameOutput
+ echo "[+] Done."
diff --git a/net-vpn/riseup-vpn/riseup-vpn-0.21.6-r1.ebuild b/net-vpn/riseup-vpn/riseup-vpn-0.21.6-r1.ebuild
index 91db3c978164..1f5d98d6c03e 100644
--- a/net-vpn/riseup-vpn/riseup-vpn-0.21.6-r1.ebuild
+++ b/net-vpn/riseup-vpn/riseup-vpn-0.21.6-r1.ebuild
@@ -94,6 +94,7 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-ip-location.patch"
"${FILESDIR}/${PN}-respect-AR.patch"
+ "${FILESDIR}/${PN}-parallel-make.patch"
)
S="${WORKDIR}/bitmask-vpn-${PV}"
@@ -112,13 +113,13 @@ src_prepare() {
src_compile() {
# does not build with j>1
tc-export AR LD CC CXX
- emake -j1 build
+ emake build
docs_compile
}
src_test() {
- emake -j1 test
- virtx emake -j1 test_ui
+ emake test
+ virtx emake test_ui
}
src_install() {