summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 07:20:31 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:43:38 +0100
commit3fed6658a89de4f819da9646435f8054821b5ff4 (patch)
tree264565d35bb0b18e0e9c7cf72d86c961b5a52fd2 /net-vpn
parentnet-vpn/ipsec-tools: fix variable references (diff)
downloadgentoo-3fed6658a89de4f819da9646435f8054821b5ff4.tar.gz
gentoo-3fed6658a89de4f819da9646435f8054821b5ff4.tar.bz2
gentoo-3fed6658a89de4f819da9646435f8054821b5ff4.zip
net-vpn/openvpn: fix variable references, missing die
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/openvpn/openvpn-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/net-vpn/openvpn/openvpn-9999.ebuild b/net-vpn/openvpn/openvpn-9999.ebuild
index 8ea466d6754f..befc78d0d7bb 100644
--- a/net-vpn/openvpn/openvpn-9999.ebuild
+++ b/net-vpn/openvpn/openvpn-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -65,7 +65,7 @@ src_configure() {
SYSTEMD_UNIT_DIR=$(systemd_get_systemunitdir) \
TMPFILES_DIR="/usr/lib/tmpfiles.d" \
econf \
- --with-plugindir="${EPREFIX}/usr/$(get_libdir)/$PN" \
+ --with-plugindir="${EPREFIX}/usr/$(get_libdir)/${PN}" \
$(use_enable inotify async-push) \
$(use_enable ssl crypto) \
$(use_with ssl crypto-library $(usex mbedtls mbedtls openssl)) \
@@ -88,7 +88,9 @@ src_test() {
src_install() {
default
- find "${ED}/usr" -name '*.la' -delete
+
+ find "${ED}/usr" -name '*.la' -delete || die
+
# install documentation
dodoc AUTHORS ChangeLog PORTS README README.IPv6