summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 20:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 19:42:20 +0100
commitbe0ab352405aa2d5d968a8c3905557b914df9626 (patch)
tree5b5da6a6ab8feb0c82b1f5c6b02e9fafdee83463 /net-vpn
parentsys-kernel/gentoo-sources: Linux patch 5.4.7 (diff)
downloadgentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.gz
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.bz2
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.zip
*/*: Switch proxy-maint to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/i2pd/i2pd-2.27.0.ebuild6
-rw-r--r--net-vpn/i2pd/i2pd-2.28.0.ebuild6
-rw-r--r--net-vpn/i2pd/i2pd-2.29.0.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/net-vpn/i2pd/i2pd-2.27.0.ebuild b/net-vpn/i2pd/i2pd-2.27.0.ebuild
index 099b9151f166..a24bc8dd650f 100644
--- a/net-vpn/i2pd/i2pd-2.27.0.ebuild
+++ b/net-vpn/i2pd/i2pd-2.27.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit systemd cmake-utils toolchain-funcs
+inherit systemd cmake toolchain-funcs
DESCRIPTION="A C++ daemon for accessing the I2P anonymous network"
HOMEPAGE="https://github.com/PurpleI2P/i2pd"
@@ -67,11 +67,11 @@ src_configure() {
-DWITH_LIBRARY=ON
-DWITH_BINARY=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# config
insinto /etc/i2pd
diff --git a/net-vpn/i2pd/i2pd-2.28.0.ebuild b/net-vpn/i2pd/i2pd-2.28.0.ebuild
index 099b9151f166..a24bc8dd650f 100644
--- a/net-vpn/i2pd/i2pd-2.28.0.ebuild
+++ b/net-vpn/i2pd/i2pd-2.28.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit systemd cmake-utils toolchain-funcs
+inherit systemd cmake toolchain-funcs
DESCRIPTION="A C++ daemon for accessing the I2P anonymous network"
HOMEPAGE="https://github.com/PurpleI2P/i2pd"
@@ -67,11 +67,11 @@ src_configure() {
-DWITH_LIBRARY=ON
-DWITH_BINARY=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# config
insinto /etc/i2pd
diff --git a/net-vpn/i2pd/i2pd-2.29.0.ebuild b/net-vpn/i2pd/i2pd-2.29.0.ebuild
index 5982e199dbce..06d8abe7e506 100644
--- a/net-vpn/i2pd/i2pd-2.29.0.ebuild
+++ b/net-vpn/i2pd/i2pd-2.29.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd cmake-utils toolchain-funcs
+inherit systemd cmake toolchain-funcs
DESCRIPTION="A C++ daemon for accessing the I2P anonymous network"
HOMEPAGE="https://github.com/PurpleI2P/i2pd"
@@ -65,11 +65,11 @@ src_configure() {
-DWITH_LIBRARY=ON
-DWITH_BINARY=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# config
insinto /etc/i2pd