summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-04-08 10:56:59 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-04-08 10:56:59 -0400
commitef1d21d069df0c52835075c994aea2ea863bac84 (patch)
tree4453f311cb470a5dbbf504826f1ef2d92cfd9b05 /net-vpn
parentwww-servers/varnish: version bump to 5.1.2 (diff)
downloadgentoo-ef1d21d069df0c52835075c994aea2ea863bac84.tar.gz
gentoo-ef1d21d069df0c52835075c994aea2ea863bac84.tar.bz2
gentoo-ef1d21d069df0c52835075c994aea2ea863bac84.zip
net-vpn/tor: version bump to 0.3.0.5_rc
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tor/Manifest1
-rw-r--r--net-vpn/tor/tor-0.3.0.5_rc.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-vpn/tor/Manifest b/net-vpn/tor/Manifest
index 8ff6c084d0f2..de54ba90aa9f 100644
--- a/net-vpn/tor/Manifest
+++ b/net-vpn/tor/Manifest
@@ -3,3 +3,4 @@ DIST tor-0.2.9.10.tar.gz 5557586 SHA256 d611283e1fb284b5f884f8c07e7d315101685184
DIST tor-0.2.9.9.tar.gz 5534005 SHA256 33325d2b250fd047ba2ddc5d11c2190c4e2951f4b03ec48ebd8bf0666e990d43 SHA512 cbe7e1f3e503b945f150916b7147cf23d1c32c3660e15aecfe5e2f2baac3a241de665e6ce4e81b81229933eba7f02d4a86e8deeabf2378d40fa83a7036928c9b WHIRLPOOL 9fc83693ea3b0519354a6d1fde83d090b66a9738f67abd7be2f9c3a36e95df92968b6da6c8cecd97ad352c70aac62817a86efae2dd42129934c2e6b38577439c
DIST tor-0.3.0.3-alpha.tar.gz 5738504 SHA256 739adb4a7ae1eb12582a667d56f7e8348123b1e00fe9d8a6159776df6dba7a87 SHA512 312b18599749252f8e66cc334481dfc8655f76717f02d3ecdcd7d278d43bc9e60e8464ab76d1a150adbb6a5468c1a03fff0db51f67ce12b9132bc772463a3849 WHIRLPOOL 2853eb585e608e098aee30fea7bf0f0c8175bc4ed1ad86a2511fc85a75bec2e8571dcf3a017986a73ceededff312c90650c83d44f7224e2de9d829f8d675c6e5
DIST tor-0.3.0.4-rc.tar.gz 5757770 SHA256 32a7c0b322c61e15ce770f43715682f8b0be47844478387ddf8444cdf7c2f46f SHA512 21b335a973c9958c6c832ca171ac5e94c78379e365e4564289a623f264f8daab30be874a083ca3867364a6008c3b447080fad940dbbbda73f0cd3bb0dbf17d08 WHIRLPOOL af587ad1ce0c8fdac8eab65a9b7fb354abab700d967bddee9f2f647ffe7d630a5fd4cd0bb8f564ef62ccc2b482d87b83fe5f061da698504836ba997690417a10
+DIST tor-0.3.0.5-rc.tar.gz 5738882 SHA256 622c9366d8b753da9192e037d0a13d2d87ffec25b5c606a3d73a2452976b43e0 SHA512 5fa8ecb8eb1d9d27fa7dc99b4fe476a5f4ec2a27dd36bade42bc4ed3a5868f55fceca2566dadb0d527b1870892f07df48f1f878a39b8c0806730017c6eb2a5fb WHIRLPOOL 83f21aac6f63aac8b3096af11f896dcdd812cd2c0adf94596ca3434d63fd454aa6d638a2fffff9de7bb2df8586309af1fd4d04aae9c194033aafa067c030324a
diff --git a/net-vpn/tor/tor-0.3.0.5_rc.ebuild b/net-vpn/tor/tor-0.3.0.5_rc.ebuild
new file mode 100644
index 000000000000..b103e82a8aed
--- /dev/null
+++ b/net-vpn/tor/tor-0.3.0.5_rc.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic readme.gentoo-r1 systemd versionator user
+
+MY_PV="$(replace_version_separator 4 -)"
+MY_PF="${PN}-${MY_PV}"
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+SRC_URI="https://www.torproject.org/dist/${MY_PF}.tar.gz
+ https://archive.torproject.org/tor-package-archive/${MY_PF}.tar.gz"
+S="${WORKDIR}/${MY_PF}"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+IUSE="libressl scrypt seccomp selinux systemd tor-hardening test web"
+
+DEPEND="
+ app-text/asciidoc
+ dev-libs/libevent[ssl]
+ sys-libs/zlib
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
+ scrypt? ( app-crypt/libscrypt )
+ seccomp? ( sys-libs/libseccomp )
+ systemd? ( sys-apps/systemd )"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-tor )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.7.4-torrc.sample.patch
+)
+
+DOCS=( README ChangeLog ReleaseNotes doc/HACKING )
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_configure() {
+ econf \
+ --localstatedir="${EPREFIX}/var" \
+ --enable-system-torrc \
+ --enable-asciidoc \
+ $(use_enable scrypt libscrypt) \
+ $(use_enable seccomp) \
+ $(use_enable systemd) \
+ $(use_enable tor-hardening gcc-hardening) \
+ $(use_enable tor-hardening linker-hardening) \
+ $(use_enable web tor2web-mode) \
+ $(use_enable test unittests) \
+ $(use_enable test coverage)
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+
+ newconfd "${FILESDIR}"/tor.confd tor
+ newinitd "${FILESDIR}"/tor.initd-r8 tor
+ systemd_dounit contrib/dist/tor.service
+
+ keepdir /var/lib/tor
+
+ fperms 750 /var/lib/tor
+ fowners tor:tor /var/lib/tor
+
+ insinto /etc/tor/
+ newins "${FILESDIR}"/torrc-r1 torrc
+}